Aller au contenu


Import PST WinHttpSendRequest failed

pst import pstimportwizard rpc

  • Veuillez vous connecter pour répondre
1 réponse à ce sujet

#1 emillion

emillion

    Nouveau membre

  • Membres
  • 2 messages

Posté 03 juin 2016 - 10:32

Bonjour à tous.

Je souhaite importer un fichier .pst sur un compte existant.

J'utilise donc ZCSPSTImportWizard-8.6.0.1307.exe sur un poste Windows 7. Sur ce poste, j'ai installé Outlook 2010 en version 32bits.

Puisque je n'ai pas accès au mot de passe du compte de destination, j'utilise le fichier XML suivant afin de pouvoir utiliser un "AuthAccount" :

<ZCSImport>
<Server name="server">
<serverName>monserveurzimbra</serverName>
<port>443</port>
<sslEnabled>1</sslEnabled>
</Server>
<Account name="user">
<userName>user@domain.com</userName>

<organizerEmail>user@domain.com</organizerEmail>
</Account>
<Account name="admin">
<userName>prov@domain.com</userName>
<password>AdminPassword</password>
</Account>
<Data name="psts">
<PST>C:\prov\user.pst</PST>
</Data>
<Options name="config1">
<importDeletedItems>0</importDeletedItems>
<importJunk>0</importJunk>
<ImportPrivateAppts>1</ImportPrivateAppts>
<ImportPartialMails>1</ImportPartialMails>
<InvalidSSLOk>1</InvalidSSLOk>
<IgnorePreviouslyImported>1</IgnorePreviouslyImported>
</Options>
<Import Server="server" TargetAccount="user" AuthAccount="admin" AdminPort="7071" AdminSSLEnabled="1" Data="psts" Options="config1" />
</ZCSImport>


L'utilisateur prov@domain.com est bien un administrateur global.

Depuis un navigateur sur la machine Windows, j'arrive bien à m'authentifier aussi bien sur l'interface d'admin via monserveurzimbra:7071 que sur le webmail via monserveurzimbra:443

Lorsque je lance l'outil ZCSPSTImportWizard, il me génère les erreurs suivantes dans le PstImportWiz__06032016_113249.log

03-06-2016 11:32:49 [1256]: ProductName: Zimbra Import Wizard for PST Files Product Version:8.6.0.1307
03-06-2016 11:32:49 [1256]: Checking for whether the XML is Config.xml. XML Path :
03-06-2016 11:32:49 [736]: Total accounts to be imported(import node): 1	
03-06-2016 11:32:51 [736]: Processing C:\prov\user.pst
03-06-2016 11:32:51 [736]: Worker thread started							
03-06-2016 11:32:51 [736]: Work arrived...C:\prov\user.pst user@domain.com
03-06-2016 11:32:51 [736]: Using default store								
03-06-2016 11:32:51 [736]: Logging on to zimbra server (monserveurzimbra:7071)
03-06-2016 11:32:52 [736]: RPC Error:- WinHttpSendRequest failed. The RPC request is logged as C:\Users\MYUSER~1\AppData\Local\Temp\ZCSPSTImportWizard\1-RPCErrorRequest.xml
03-06-2016 11:32:52 [736]: Deleting mapi folder list						
03-06-2016 11:32:52 [736]: RPC Error: Unable to connect.					
03-06-2016 11:32:52 [736]: Using default store								
03-06-2016 11:32:52 [736]: Logging on to zimbra server (monserveurzimbra:7071)
03-06-2016 11:32:53 [736]: RPC Error:- WinHttpSendRequest failed. The RPC request is logged as C:\Users\MYUSER~1\AppData\Local\Temp\ZCSPSTImportWizard\2-RPCErrorRequest.xml
03-06-2016 11:32:53 [736]: Deleting mapi folder list						
03-06-2016 11:32:53 [736]: RPC Error: Unable to connect.					
03-06-2016 11:32:53 [736]: Using default store								
03-06-2016 11:32:53 [736]: Logging on to zimbra server (monserveurzimbra:7071)
03-06-2016 11:32:54 [736]: RPC Error:- WinHttpSendRequest failed. The RPC request is logged as C:\Users\MYUSER~1\AppData\Local\Temp\ZCSPSTImportWizard\3-RPCErrorRequest.xml
03-06-2016 11:32:54 [736]: Deleting mapi folder list						
03-06-2016 11:32:54 [736]: RPC Error: Unable to connect.					
03-06-2016 11:32:54 [736]: Using default store								
03-06-2016 11:32:54 [736]: Logging on to zimbra server (monserveurzimbra:7071)
03-06-2016 11:32:55 [736]: RPC Error:- WinHttpSendRequest failed. The RPC request is logged as C:\Users\MYUSER~1\AppData\Local\Temp\ZCSPSTImportWizard\4-RPCErrorRequest.xml																
03-06-2016 11:32:55 [736]: Deleting mapi folder list						
03-06-2016 11:32:55 [736]: RPC Error: Unable to connect.					
03-06-2016 11:32:55 [736]: Too many items failed, exiting					
03-06-2016 11:32:55 [736]: IPROFADMIN RefCount: 0							
03-06-2016 11:32:55 [736]: Worker thread exiting							
03-06-2016 11:32:55 [736]:													
03-06-2016 11:32:55 [736]: PST Import had Errors or Warnings				
Total Errors: 4															
Total Warnings: 0															

Et les 3 fichiers RPCErrorRequest.xml contiennent tous :

<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope">
<soap:Header>
<context xmlns="urn:zimbra">
	 <nonotify/><noqualify/><nosession/></context>
</soap:Header>
<soap:Body>
<AuthRequest xmlns="urn:zimbraAdmin">
	 <name>prov@domain.com</name>
	 <password>*******</password>
</AuthRequest>
</soap:Body>
</soap:Envelope>

Le serveur Zimbra en question est un Open Source 8.6 avec le patch 6.

J'ai essayé de reproduire la chose sur une infra de test en spawnant un nouveau serveur Zimbra et une VM windows 7 et j'arrive bien à utiliser l'outil avec le même PST et fichier de conf (en modifiant bien évidemment le serveur et compte de destination). J'ai aussi essayé depuis cette nouvelle VM de test vers le serveur Zimbra de prod et même erreur de WinHttpRequest qui fail.
J'imagine donc que le problème viendrait d'une conf sur mon serveur, mais laquelle ?

Pour finir, voici les logs sur le serveur Zimbra de prod (sur lequel ça ne fonctionne pas) :
2016-06-03 11:10:58,716 INFO  [qtp509886383-1484875:http://192.168.100.17:8080/service/soap/] [name=prov@domain.com;ip=192.168.100.17;] soap - AuthRequest elapsed=1
2016-06-03 11:10:58,727 INFO  [qtp509886383-1484869:http://192.168.100.17:8080/service/soap/] [name=prov@domain.com;mid=280;ip=192.168.100.17;] soap - GetInfoRequest elapsed=6
2016-06-03 11:10:58,759 INFO  [qtp509886383-1484873:https://192.168.100.17:7071/service/admin/soap/] [name=prov@domain.com;ip=192.168.100.146;] soap - AuthRequest elapsed=1
2016-06-03 11:10:58,769 INFO  [qtp509886383-1484864:https://192.168.100.17:7071/service/admin/soap/] [name=prov@domain.com;mid=280;ip=192.168.100.146;] soap - GetInfoRequest elapsed=8
2016-06-03 11:10:58,778 INFO  [qtp509886383-1484869:https://192.168.100.17:7071/service/admin/soap/] [name=prov@domain.com;mid=280;ip=192.168.100.146;] misc - delegated access: doc=GetAccount, authenticated account=prov@domain.com, target account=user@domain.com
2016-06-03 11:10:58,778 INFO  [qtp509886383-1484869:https://192.168.100.17:7071/service/admin/soap/] [name=prov@domain.com;mid=280;ip=192.168.100.146;] misc - delegated access: doc=GetAccount, authenticated account=prov@domain.com, target account=user@domain.com																																																						
2016-06-03 11:10:58,779 INFO  [qtp509886383-1484869:https://192.168.100.17:7071/service/admin/soap/] [name=prov@domain.com;mid=280;ip=192.168.100.146;] soap - GetAccountRequest elapsed=2
2016-06-03 11:10:58,787 INFO  [qtp509886383-1484878:https://192.168.100.17:7071/service/admin/soap/] [name=prov@domain.com;mid=280;ip=192.168.100.146;] soap - GetDomainRequest elapsed=0
2016-06-03 11:11:00,877 INFO  [qtp509886383-1484875:https://192.168.100.17:7071/service/admin/soap/zextras] [name=prov@domain.com;mid=280;ip=192.168.100.146;ua=ZimbraWebClient - FF45 (Win);] soap - zextras elapsed=1

Et les logs sur le serveur Zimbra de test (sur lequel ça fonctionne) :
2016-06-03 08:19:35,576 INFO  [qtp509886383-535:https://10.0.99.244:8443/service/soap/] [name=prov@zimbra86.test;ip=10.0.99.244;] soap - AuthRequest elapsed=3
2016-06-03 08:19:35,685 INFO  [qtp509886383-535:https://10.0.99.244:8443/service/soap/] [name=prov@zimbra86.test;mid=28;ip=10.0.99.244;] soap - GetInfoRequest elapsed=64
2016-06-03 08:19:35,799 INFO  [qtp509886383-535:https://10.0.99.244:7071/service/admin/soap/] [name=prov@zimbra86.test;ip=172.44.0.11;] soap - AuthRequest elapsed=3
2016-06-03 08:19:35,848 INFO  [qtp509886383-542:https://10.0.99.244:7071/service/admin/soap/] [name=prov@zimbra86.test;mid=28;ip=172.44.0.11;] soap - GetInfoRequest elapsed=5
2016-06-03 08:19:35,897 INFO  [qtp509886383-535:https://10.0.99.244:7071/service/admin/soap/] [name=prov@zimbra86.test;mid=28;ip=172.44.0.11;] misc - delegated access: doc=GetAccount, authenticated account=prov@zimbra86.test, target account=user@zimbra86.test
2016-06-03 08:19:35,898 INFO  [qtp509886383-535:https://10.0.99.244:7071/service/admin/soap/] [name=prov@zimbra86.test;mid=28;ip=172.44.0.11;] soap - GetAccountRequest elapsed=1
2016-06-03 08:19:35,949 INFO  [qtp509886383-542:https://10.0.99.244:7071/service/admin/soap/] [name=prov@zimbra86.test;mid=28;ip=172.44.0.11;] soap - GetDomainRequest elapsed=1
2016-06-03 08:19:36,383 INFO  [qtp509886383-542:https://10.0.99.244:7071/service/admin/soap/] [name=prov@zimbra86.test;ip=172.44.0.11;] soap - AuthRequest elapsed=3
2016-06-03 08:19:36,433 INFO  [qtp509886383-535:https://10.0.99.244:7071/service/admin/soap/] [name=prov@zimbra86.test;mid=28;ip=172.44.0.11;] soap - GetInfoRequest elapsed=5
2016-06-03 08:19:36,483 INFO  [qtp509886383-542:https://10.0.99.244:7071/service/admin/soap/] [name=user@zimbra86.test;aname=prov@zimbra86.test;mid=27;ip=172.44.0.11;] soap - GetFolderRequest elapsed=2
2016-06-03 08:19:36,549 INFO  [qtp509886383-535:https://10.0.99.244:7071/service/admin/soap/] [name=user@zimbra86.test;aname=prov@zimbra86.test;mid=27;ip=172.44.0.11;] soap - GetTagRequest elapsed=1										

Si quelqu'un a une idée ? :D
Zimbra 8.6 FOSS (ubuntu 14.04)

#2 emillion

emillion

    Nouveau membre

  • Membres
  • 2 messages

Posté 06 juin 2016 - 07:44

J'avance un petit peu.
Le problème surgit sur toutes les anciennes instances Zimbra (celles qui ont subit des mises à jour et ne sont pas installées directement en 8.5+).
Donc soit une configuration qui date d'une ancienne version qui n'aurait pas été updaté, soit juste une config qui a été faite sur le serveur avant.

En tout cas, ça doit concerner l'admin vu que l'import via la GUI (et donc en utilisant le login/mdp de l'utilisateur déstinataire) fonctionne.

EDIT : Je viens de faire un test d'upgrade d'un Zimbra 7.1.4 > 8.0.9 > 8.6 et l'import fonctionne, le problème vient donc d'une config sur les anciennes instances Zimbra... Mais laquelle ? ^^
Zimbra 8.6 FOSS (ubuntu 14.04)





Aussi étiqueté avec au moins un de ces mots-clés : pst, import, pstimportwizard, rpc

0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)