Aller au contenu


Serveur Zimbra HS après redémarrage (Erreur LDAP)


  • Veuillez vous connecter pour répondre
31 réponses à ce sujet

#1 JYvViva

JYvViva

    Membre avancé

  • Membres
  • 32 messages

Posté 20 avril 2016 - 12:45

Bonjour Team,

Suite à un arrêt brusque (incident électrique) de mon serveur Zimbra, je suis confronté à une erreur LDAP qui empêche les services annexes de démarrer.


[zimbra@mail ~]$ zmcontrol start

Host mail.x.y
        Starting ldap...Done.
Search error: Unable to determine enabled services from ldap.
Enabled services read from cache. Service list may be inaccurate.
        Starting zmconfigd...Failed.
Starting zmconfigd...failed.


        Starting logger...Failed.
Starting logswatch...[] INFO: master is down, falling back to replica...
[] FATAL: failed to initialize LDAP client
com.zimbra.cs.ldap.LdapException: LDAP error: : invalid credentials
ExceptionId:main:1461154102405:f0399b34a76eb0cc
Code:ldap.LDAP_ERROR
        at com.zimbra.cs.ldap.LdapException.LDAP_ERROR(LdapException.java:90)
        at com.zimbra.cs.ldap.unboundid.UBIDLdapException.mapToLdapException(UBIDLdapException.java:74)
        at com.zimbra.cs.ldap.unboundid.UBIDLdapException.mapToLdapException(UBIDLdapException.java:40)
        at com.zimbra.cs.ldap.unboundid.LdapConnectionPool.createConnPool(LdapConnectionPool.java:117)
        at com.zimbra.cs.ldap.unboundid.LdapConnectionPool.createConnectionPool(LdapConnectionPool.java:63)
        at com.zimbra.cs.ldap.unboundid.UBIDLdapContext.init(UBIDLdapContext.java:101)
        at com.zimbra.cs.ldap.unboundid.UBIDLdapClient.init(UBIDLdapClient.java:39)
        at com.zimbra.cs.ldap.LdapClient.getInstance(LdapClient.java:65)
        at com.zimbra.cs.ldap.LdapClient.initialize(LdapClient.java:88)
        at com.zimbra.cs.account.ldap.LdapProv.<init>(LdapProv.java:48)
        at com.zimbra.cs.account.ldap.LdapProvisioning.<init>(LdapProvisioning.java:265)
        at com.zimbra.cs.account.ldap.LdapProvisioning.<init>(LdapProvisioning.java:262)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:408)
        at java.lang.Class.newInstance(Class.java:433)
        at com.zimbra.cs.account.Provisioning.getInstance(Provisioning.java:286)
        at com.zimbra.cs.account.Provisioning.getInstance(Provisioning.java:243)
        at com.zimbra.cs.account.ProvUtil.initProvisioning(ProvUtil.java:810)
        at com.zimbra.cs.account.ProvUtil.main(ProvUtil.java:3691)
Caused by: LDAPException(resultCode=49 (invalid credentials), errorMessage='invalid credentials')
        at com.unboundid.ldap.sdk.LDAPConnection.bind(LDAPConnection.java:1894)
        at com.unboundid.ldap.sdk.LDAPConnectionPool.createConnection(LDAPConnectionPool.java:988)
        at com.unboundid.ldap.sdk.LDAPConnectionPool.<init>(LDAPConnectionPool.java:876)
        at com.unboundid.ldap.sdk.LDAPConnectionPool.<init>(LDAPConnectionPool.java:779)
        at com.unboundid.ldap.sdk.LDAPConnectionPool.<init>(LDAPConnectionPool.java:726)
        at com.zimbra.cs.ldap.unboundid.LdapConnectionPool.createConnPool(LdapConnectionPool.java:112)
        ... 17 more
zimbra logger service is not enabled!  failed.


        Starting mailbox...Failed.


        Starting memcached...Done.
        Starting amavis...Done.
        Starting antispam...Done.
        Starting antivirus...Done.
        Starting opendkim...Failed.
/opt/zimbra/bin/zmopendkimctl: line 54: kill: (5055) - No such process
opendkim: /opt/zimbra/conf/opendkim.conf: ldap://mail.x.y:389/?DKIMSelector?sub?(DKIMIdentity=$d): dkimf_db_open(): Invalid credentials
Failed to start opendkim: 0


        Starting snmp...Done.
        Starting spell...Done.
        Starting mta...Done.
        Starting stats...Done.


Je suis dans le pétrin s'il vous plaît. Chers Experts, Merci de m'accorder une minute de votre temps afin de diagnostiquer le problème.


Note : Avant le brusque redémarrage, le serveur fonctionnait nickel sans souci depuis plus de 05 mois

VM, VMware ESXi 5.5, IBM Bladecenter H, Lame HX5, 04 CPU Intel Xeon E7- 4807  @ 1.87GHz, 16 Go RAM, CentOS 7 64bit, ZCS 8.6 64bit OSE

#2 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 766 messages
  • LocalisationPlanète Terre

Posté 20 avril 2016 - 13:06

dèjà stop tout.
Ensuite démarre uniquement le ldap zimbra et regarde les logs.
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr
http://www.scalesi.fr/

#3 JYvViva

JYvViva

    Membre avancé

  • Membres
  • 32 messages

Posté 20 avril 2016 - 13:51

Lorsque je lance uniquement le LDAP, tout est ok. Aucun souci.
Par contre, si j'essaye de lancer le Logger, j'obtient les mêmes erreurs que plus haut
VM, VMware ESXi 5.5, IBM Bladecenter H, Lame HX5, 04 CPU Intel Xeon E7- 4807  @ 1.87GHz, 16 Go RAM, CentOS 7 64bit, ZCS 8.6 64bit OSE

#4 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 766 messages
  • LocalisationPlanète Terre

Posté 20 avril 2016 - 13:57

ton zmlocalconfig n'as plus les mots de passe apparemment.
zmlocalconfig -s | grep ldap | grep pass
ça donne quoi ?

Peux-tu utiliser les mots de passe avec une requête ldap ? Si non, il faudrait les réinitialiser notamment celui
associé à Zimbra.
Le mot de passe root du ldap ne peux être modifier qu'en éditant un fichier particulier.
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr
http://www.scalesi.fr/

#5 JYvViva

JYvViva

    Membre avancé

  • Membres
  • 32 messages

Posté 20 avril 2016 - 14:04

zmlocalconfig -s | grep ldap | grep pass


ça affiche les différents mots de passe .

ldap_amavis_password = xxxx
ldap_bes_searcher_password = xxxx
ldap_nginx_password = xxxx
ldap_postfix_password = xxxx
ldap_replication_password = xxxx
ldap_root_password = xxxx
zimbra_ldap_password = xxxx


Je ne m'y connais côté requête LDAP. Serait-ce possible de me communiquer quelques unes ? Merci
VM, VMware ESXi 5.5, IBM Bladecenter H, Lame HX5, 04 CPU Intel Xeon E7- 4807  @ 1.87GHz, 16 Go RAM, CentOS 7 64bit, ZCS 8.6 64bit OSE

#6 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 766 messages
  • LocalisationPlanète Terre

Posté 20 avril 2016 - 14:14

ldapsearch -LLL -h localhost -p 389 -D  uid=zimbra,cn=admins,cn=zimbra -W
Au prompt tu mets le mot de passe correspondant à ce champ = zimbra_ldap_password
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr
http://www.scalesi.fr/

#7 JYvViva

JYvViva

    Membre avancé

  • Membres
  • 32 messages

Posté 20 avril 2016 - 14:20

$ ldapsearch -LLL -h localhost -p 389 -D  uid=zimbra,cn=admins,cn=zimbra -W
Enter LDAP Password:
ldap_sasl_bind(SIMPLE): Can't contact LDAP server (-1)

VM, VMware ESXi 5.5, IBM Bladecenter H, Lame HX5, 04 CPU Intel Xeon E7- 4807  @ 1.87GHz, 16 Go RAM, CentOS 7 64bit, ZCS 8.6 64bit OSE

#8 Klug

Klug

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 10 456 messages
  • LocalisationPlaisians - Drôme

Posté 20 avril 2016 - 14:55

Vérifie les droits sur le localconfig.xml (et les autres fichiers).
Ce serait propriété de "root" et lisible par lui uniquement (après un fdisk post-plantage) que ça ne m'étonnerait pas.

#9 JYvViva

JYvViva

    Membre avancé

  • Membres
  • 32 messages

Posté 20 avril 2016 - 14:58

ls -l localconfig.xml
-rw-r----- 1 zimbra zimbra 4464 Sep  8  2015 localconfig.xml

VM, VMware ESXi 5.5, IBM Bladecenter H, Lame HX5, 04 CPU Intel Xeon E7- 4807  @ 1.87GHz, 16 Go RAM, CentOS 7 64bit, ZCS 8.6 64bit OSE

#10 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 766 messages
  • LocalisationPlanète Terre

Posté 20 avril 2016 - 16:14

Dans le doute en root, faire :
/opt/zimbra/libexec/zmfixperms -verbose
Ensuite refaire la manip ldapsearch
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr
http://www.scalesi.fr/

#11 JYvViva

JYvViva

    Membre avancé

  • Membres
  • 32 messages

Posté 20 avril 2016 - 16:33

Malgré le zmfixperms, le résultat est toujours le même.
ldap_sasl_bind(SIMPLE): Can't contact LDAP server (-1)

VM, VMware ESXi 5.5, IBM Bladecenter H, Lame HX5, 04 CPU Intel Xeon E7- 4807  @ 1.87GHz, 16 Go RAM, CentOS 7 64bit, ZCS 8.6 64bit OSE

#12 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 766 messages
  • LocalisationPlanète Terre

Posté 20 avril 2016 - 16:36

J'avais pas vu le message d'erreur suivant :
Can't contact LDAP server (-1)
Problème DNS, /etc/hosts ect...
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr
http://www.scalesi.fr/

#13 JYvViva

JYvViva

    Membre avancé

  • Membres
  • 32 messages

Posté 20 avril 2016 - 16:55

Le contenu de /etc/hosts
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1		 localhost localhost.localdomain localhost6 localhost6.localdomain6
192.168.x.y	mail.x.y	mail

le contenu de /etc/resolv.conf
; generated by /sbin/dhclient-script
search domain.xxx
nameserver 192.168.x.y

nslookup et dig mx eux aussi sont ok
[zimbra@mail ~]$ nslookup mail
Server:		 192.168.x.y
Address:		192.168.x.y#53
Name:   mail.x.y
Address: 192.168.x.y

[zimbra@mail ~]$ dig mx mail
; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.30.rc1.el6 <<>> mx mail
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 23395
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
;; QUESTION SECTION:
;mail.						  IN	  MX
;; AUTHORITY SECTION:
.					   10800   IN	  SOA	 a.root-servers.net. nstld.verisign-grs.com. 2016042000 1800 900 604800 86400
;; Query time: 184 msec
;; SERVER: 192.168.x.y#53(192.168.x.y)
;; WHEN: Wed Apr 20 17:20:59 2016
;; MSG SIZE  rcvd: 97

Tout fonctionnait ainsi avant l'incident électrique.
VM, VMware ESXi 5.5, IBM Bladecenter H, Lame HX5, 04 CPU Intel Xeon E7- 4807  @ 1.87GHz, 16 Go RAM, CentOS 7 64bit, ZCS 8.6 64bit OSE

#14 JYvViva

JYvViva

    Membre avancé

  • Membres
  • 32 messages

Posté 20 avril 2016 - 18:49

Any update please ?
VM, VMware ESXi 5.5, IBM Bladecenter H, Lame HX5, 04 CPU Intel Xeon E7- 4807  @ 1.87GHz, 16 Go RAM, CentOS 7 64bit, ZCS 8.6 64bit OSE

#15 wolfy

wolfy

    Zimbra Jedi

  • Modérateurs
  • 569 messages
  • LocalisationRouen, France

Posté 21 avril 2016 - 07:04

Essaye de mettre ca dans ton /etc/hosts :
127.0.0.1   localhost.localdomain localhost
192.168.x.y     mail.x.y        mail
::1              localhost.localdomain localhost
___
Senior Solution Advisor EMEA chez Vade Secure

#16 JYvViva

JYvViva

    Membre avancé

  • Membres
  • 32 messages

Posté 21 avril 2016 - 07:50

Bonjour Wolfy,

Hélas, le résultat est le même que celui affiché dans mon tout premier post.

Citation

Host mail.x.y
Starting ldap...Done.
Search error: Unable to determine enabled services from ldap.
Enabled services read from cache. Service list may be inaccurate.
Starting zmconfigd...Failed.

Starting zmconfigd...failed.

VM, VMware ESXi 5.5, IBM Bladecenter H, Lame HX5, 04 CPU Intel Xeon E7- 4807  @ 1.87GHz, 16 Go RAM, CentOS 7 64bit, ZCS 8.6 64bit OSE

#17 wolfy

wolfy

    Zimbra Jedi

  • Modérateurs
  • 569 messages
  • LocalisationRouen, France

Posté 21 avril 2016 - 08:29

si tu fait ca :
su - zimbra
zmcontrol stop
ldap start
et dans les log /var/log/zimbra.log
dis nous ce que tu as
___
Senior Solution Advisor EMEA chez Vade Secure

#18 JYvViva

JYvViva

    Membre avancé

  • Membres
  • 32 messages

Posté 21 avril 2016 - 08:53

Voici le résultat

Citation

Apr 21 09:10:51 mail zimbramon[3832]: 3832:info: Stopping opendkim via zmcontrol
Apr 21 09:10:52 mail zimbramon[3832]: 3832:info: Stopping amavis via zmcontrol
Apr 21 09:10:52 mail zimbramon[3832]: 3832:info: Stopping antivirus via zmcontrol
Apr 21 09:10:53 mail clamd[18586]: Pid file removed.
Apr 21 09:10:53 mail clamd[18586]: --- Stopped at Thu Apr 21 09:10:53 2016
Apr 21 09:10:53 mail clamd[18586]: Socket file removed.
Apr 21 09:10:54 mail zimbramon[3832]: 3832:info: Stopping antispam via zmcontrol
Apr 21 09:10:55 mail zimbramon[3832]: 3832:info: Stopping proxy via zmcontrol
Apr 21 09:10:55 mail zimbramon[3832]: 3832:info: Stopping memcached via zmcontrol
Apr 21 09:10:56 mail zimbramon[3832]: 3832:info: Stopping mailbox via zmcontrol
Apr 21 09:10:56 mail zmmailboxdmgr[4490]: stale pid 21831 found in /opt/zimbra/log/zmmailboxd_manager.pid: No such process
Apr 21 09:10:56 mail zmmailboxdmgr[4490]: assuming no other instance is running
Apr 21 09:10:56 mail zmmailboxdmgr[4490]: file /opt/zimbra/log/zmmailboxd.pid does not exist
Apr 21 09:10:56 mail zmmailboxdmgr[4490]: assuming no other instance is running
Apr 21 09:10:56 mail zmmailboxdmgr[4490]: no manager process is running
Apr 21 09:10:56 mail zimbramon[3832]: 3832:info: Stopping convertd via zmcontrol
Apr 21 09:10:56 mail zimbramon[3832]: 3832:info: Stopping logger via zmcontrol
Apr 21 09:10:56 mail zimbramon[3832]: 3832:info: Stopping dnscache via zmcontrol
Apr 21 09:10:56 mail zimbramon[3832]: 3832:info: Stopping ldap via zmcontrol
Apr 21 09:10:56 mail slapd[16956]: daemon: shutdown requested and initiated.
Apr 21 09:10:56 mail slapd[16956]: slapd shutdown: waiting for 0 operations/tasks to finish
Apr 21 09:10:56 mail slapd[16956]: DIGEST-MD5 common mech free
Apr 21 09:10:56 mail slapd[16956]: slapd stopped.
Apr 21 09:12:03 mail zmmailboxdmgr[4789]: stale pid 21831 found in /opt/zimbra/log/zmmailboxd_manager.pid: No such process
Apr 21 09:12:03 mail zmmailboxdmgr[4789]: assuming no other instance is running
Apr 21 09:12:03 mail zmmailboxdmgr[4789]: file /opt/zimbra/log/zmmailboxd.pid does not exist
Apr 21 09:12:03 mail zmmailboxdmgr[4789]: assuming no other instance is running
Apr 21 09:12:03 mail zmmailboxdmgr[4789]: no manager process is running
Apr 21 09:12:03 mail zmmailboxdmgr[4856]: stale pid 21831 found in /opt/zimbra/log/zmmailboxd_manager.pid: No such process
Apr 21 09:12:03 mail zmmailboxdmgr[4856]: assuming no other instance is running
Apr 21 09:12:03 mail zmmailboxdmgr[4856]: file /opt/zimbra/log/zmmailboxd.pid does not exist
Apr 21 09:12:03 mail zmmailboxdmgr[4856]: assuming no other instance is running
Apr 21 09:12:03 mail zmmailboxdmgr[4856]: no manager process is running
Apr 21 09:12:04 mail zmmailboxdmgr[4934]: stale pid 21831 found in /opt/zimbra/log/zmmailboxd_manager.pid: No such process
Apr 21 09:12:04 mail zmmailboxdmgr[4934]: assuming no other instance is running
Apr 21 09:12:04 mail zmmailboxdmgr[4934]: file /opt/zimbra/log/zmmailboxd.pid does not exist
Apr 21 09:12:04 mail zmmailboxdmgr[4934]: assuming no other instance is running
Apr 21 09:12:04 mail zmmailboxdmgr[4934]: no manager process is running
Apr 21 09:12:04 mail zmmailboxdmgr[4963]: stale pid 21831 found in /opt/zimbra/log/zmmailboxd_manager.pid: No such process
Apr 21 09:12:04 mail zmmailboxdmgr[4963]: assuming no other instance is running
Apr 21 09:12:04 mail zmmailboxdmgr[4963]: file /opt/zimbra/log/zmmailboxd.pid does not exist
Apr 21 09:12:04 mail zmmailboxdmgr[4963]: assuming no other instance is running
Apr 21 09:12:04 mail zmmailboxdmgr[4963]: no manager process is running
Apr 21 09:12:04 mail zmmailboxdmgr[4992]: stale pid 21831 found in /opt/zimbra/log/zmmailboxd_manager.pid: No such process
Apr 21 09:12:04 mail zmmailboxdmgr[4992]: assuming no other instance is running
Apr 21 09:12:04 mail zmmailboxdmgr[4992]: file /opt/zimbra/log/zmmailboxd.pid does not exist
Apr 21 09:12:04 mail zmmailboxdmgr[4992]: assuming no other instance is running
Apr 21 09:12:04 mail zmmailboxdmgr[4992]: no manager process is running
Apr 21 09:13:37 mail slapd[5045]: @(#) $OpenLDAP: slapd 2.4.39 (Dec  2 2014 21:22:26) $#012#011build@zre-rhel6-64.eng.zimbra.com:/home/build/p4/zimbra/JUDASPRIEST-860/ThirdParty/openldap/openldap-2.4.39.2z/servers/slapd
Apr 21 09:13:38 mail slapd[5046]: slapd starting


VM, VMware ESXi 5.5, IBM Bladecenter H, Lame HX5, 04 CPU Intel Xeon E7- 4807  @ 1.87GHz, 16 Go RAM, CentOS 7 64bit, ZCS 8.6 64bit OSE

#19 wolfy

wolfy

    Zimbra Jedi

  • Modérateurs
  • 569 messages
  • LocalisationRouen, France

Posté 21 avril 2016 - 09:01

et apres cette ligne ?
Apr 21 09:13:37 mail slapd[5045]: @(#) $OpenLDAP: slapd 2.4.39 (Dec  2 2014 21:22:26) $#012#011build@zre-rhel6-64.eng.zimbra.com:/home/build/p4/zimbra/JUDASPRIEST-860/ThirdParty/openldap/openldap-2.4.39.2z/servers/slapd
Apr 21 09:13:38 mail slapd[5046]: slapd starting
___
Senior Solution Advisor EMEA chez Vade Secure

#20 JYvViva

JYvViva

    Membre avancé

  • Membres
  • 32 messages

Posté 21 avril 2016 - 10:36

Le même style d'information sur les process qui ne sont pas en cours d'exécution.
VM, VMware ESXi 5.5, IBM Bladecenter H, Lame HX5, 04 CPU Intel Xeon E7- 4807  @ 1.87GHz, 16 Go RAM, CentOS 7 64bit, ZCS 8.6 64bit OSE




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)