Aller au contenu


Synchro GAL sur Active Directory


  • Veuillez vous connecter pour répondre
14 réponses à ce sujet

#1 bartounet

bartounet

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 2 825 messages
  • LocalisationAngoulême

Posté 13 mars 2010 - 17:28

Bonjour,
J'ai voulu synchroniser ma GAL ZCS avec celle de l'AD.
Après avoir pas mal galéré. J'ai enfin réussi.

Dans la console d'admin, cliquer sur votre domaine à synchro, configurer la liste gal

Bien sur utiliser l'option Active directory ne fonctionne pas... il faut donc activer serveur LDAP et mettre les filtres de recherche suivants..

ldap://ip_du_dc port 3268

Mode GAL :
Interne et externe
Nombre maximum de résultats renvoyés par les recherches GAL :
Compte à synchroniser avec la liste GAL :* galsync@domaine.fr
Nom de la source de données pour la liste GAL interne :
Intervalle de consultation de la liste GAL (interne) : 1 days
Nom de la source de données pour la liste GAL externe : galsync@domaine.fr
Intervalle de consultation de la liste GAL (externe) :
Type de serveur : LDAP
Filtre LDAP :* (&(|(cn=%s*)(sn=%s*)(gn=%s*)(mail=%s*)))
Saisie semi-automatique du filtre : (|(cn=%s*)(sn=%s*)(gn=%s*)(mail=%s*))
Base de recherche LDAP : dc=mondomaine,dc=priv
URL LDAP : ldap://ip_domaincontroler:3268
Associer un identifiant (DN) : ldapview

si ca peut vous aider...

Modifié par bartounet, 13 mars 2010 - 17:58.

Serveur Production 2 Dell R905 128Go Ram cluster DRBD Xen 3.2 - SLES11 64bits
Zimbra NE V7.1.4 Xen SLES11-SP1 Paravirtualized (DomU 4Vcpus 8Go ram) - Prod 200 users
Serveur Perso HP Proliant DL120 DEDIBOX PRO Xeon® E3-1220 16Go Ram Opensuse 12.1 64bits Virtualisation Xen4
Zimbra OSE V8 Xen Ubuntu 10.04 LTS 64 bits Paravirtualized (DomU 2Vcpus 4Go ram) + Zextras - Potes et assoc
Auto-entreprise: Solutions informatiques sur mesure : http://www.info16.fr
Mon blog : http://blog.info16.fr
Image IPBImage IPBImage IPB

#2 bartounet

bartounet

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 2 825 messages
  • LocalisationAngoulême

Posté 13 mars 2010 - 18:54

Je précise qu'il y a pas mal d'exemple sur le forum US

Modifié par bartounet, 13 mars 2010 - 18:54.

Serveur Production 2 Dell R905 128Go Ram cluster DRBD Xen 3.2 - SLES11 64bits
Zimbra NE V7.1.4 Xen SLES11-SP1 Paravirtualized (DomU 4Vcpus 8Go ram) - Prod 200 users
Serveur Perso HP Proliant DL120 DEDIBOX PRO Xeon® E3-1220 16Go Ram Opensuse 12.1 64bits Virtualisation Xen4
Zimbra OSE V8 Xen Ubuntu 10.04 LTS 64 bits Paravirtualized (DomU 2Vcpus 4Go ram) + Zextras - Potes et assoc
Auto-entreprise: Solutions informatiques sur mesure : http://www.info16.fr
Mon blog : http://blog.info16.fr
Image IPBImage IPBImage IPB

#3 androme

androme

    Modérateur Grognon

  • Modérateurs
  • 1 795 messages
  • LocalisationArles

Posté 13 mars 2010 - 19:09

heuuuu à mon boulot la gal fonctionne très bien avec le mode active directory hein.
7.1.3 NE   : IBM 3350 -> SAN FC (SLES 11 x64 sous vSphere) 750 Users (~ 1000 en fin de migration)
7.1.3 OSE : IBM 3350 -> SAN FC  (SLES 11 x64 sous vSphere)750 Users

#4 Klug

Klug

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 10 140 messages
  • LocalisationBeaucaire - Gard

Posté 13 mars 2010 - 19:29

Citation

heuuuu à mon boulot la gal fonctionne très bien avec le mode active directory hein.
Les adresses mails (@serveur-zimbra) correspondent aux UIN (dans l'AD), non ?

En général, ça ne matche pas.
Genre "prenom.nom@domaine.tld" sur le serveur Zimbra et "login" (initiale du prénom et nom par exemple) sur l'AD.

#5 androme

androme

    Modérateur Grognon

  • Modérateurs
  • 1 795 messages
  • LocalisationArles

Posté 14 mars 2010 - 21:02

ah bein vi alors car chez nous ca correspond.
7.1.3 NE   : IBM 3350 -> SAN FC (SLES 11 x64 sous vSphere) 750 Users (~ 1000 en fin de migration)
7.1.3 OSE : IBM 3350 -> SAN FC  (SLES 11 x64 sous vSphere)750 Users

#6 bartounet

bartounet

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 2 825 messages
  • LocalisationAngoulême

Posté 14 mars 2010 - 21:05

seul probleme pour ma part, c'est qu'il sort aussi les serveurs...
Lol je me retrouve avec des noms de serveurs, d'imprimantes...
Serveur Production 2 Dell R905 128Go Ram cluster DRBD Xen 3.2 - SLES11 64bits
Zimbra NE V7.1.4 Xen SLES11-SP1 Paravirtualized (DomU 4Vcpus 8Go ram) - Prod 200 users
Serveur Perso HP Proliant DL120 DEDIBOX PRO Xeon® E3-1220 16Go Ram Opensuse 12.1 64bits Virtualisation Xen4
Zimbra OSE V8 Xen Ubuntu 10.04 LTS 64 bits Paravirtualized (DomU 2Vcpus 4Go ram) + Zextras - Potes et assoc
Auto-entreprise: Solutions informatiques sur mesure : http://www.info16.fr
Mon blog : http://blog.info16.fr
Image IPBImage IPBImage IPB

#7 Klug

Klug

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 10 140 messages
  • LocalisationBeaucaire - Gard

Posté 15 mars 2010 - 08:13

Je reviens sur ce que j'ai dit.

Ce dont je parlais qui nécessitait de passer en mode LDAP (et pas en mode AD) c'est l'auth externe, pas la GAL externe.
La GAL externe, ça marche directement en mode AD (et ça ne sort que les utilisateurs).

	Mode GAL : Externe
	Nombre maximum de résultats renvoyés par les recherches GAL : 100
	Compte à synchroniser avec la liste GAL : galsync@domaine-zimbra.tld
	Nom de la source de données pour la liste GAL interne : zimbra
	Intervalle de consultation de la liste GAL (interne) : 100	jours
	Nom de la source de données pour la liste GAL externe : AD
	Intervalle de consultation de la liste GAL (externe) : 1 heures
	Type de serveur : Active Directory
	Filtre LDAP : ad
	Saisie semi-automatique du filtre : adAutoComplete
	Base de recherche LDAP : dc=domaine-ad,dc=tld
	URL LDAP : ldap://serveur-ad:3268
	Associer un identifiant (DN) : cn=zimbra,cn=users,dc=domaine-ad,dc=tld

Il y a un compte zimbra créé dans l'AD, avec les bons droits (que je n'ai plus sous la main).

#8 bartounet

bartounet

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 2 825 messages
  • LocalisationAngoulême

Posté 15 mars 2010 - 10:51

J'ai beau essayer avec ces paramètres, il ne veut rien savoir.
Il s'authentifie, mais ne me sort aucun résultat...
Alors qu''avec ldap ca fonctionne.. je dois avoir une arborescence AD batarde...
Serveur Production 2 Dell R905 128Go Ram cluster DRBD Xen 3.2 - SLES11 64bits
Zimbra NE V7.1.4 Xen SLES11-SP1 Paravirtualized (DomU 4Vcpus 8Go ram) - Prod 200 users
Serveur Perso HP Proliant DL120 DEDIBOX PRO Xeon® E3-1220 16Go Ram Opensuse 12.1 64bits Virtualisation Xen4
Zimbra OSE V8 Xen Ubuntu 10.04 LTS 64 bits Paravirtualized (DomU 2Vcpus 4Go ram) + Zextras - Potes et assoc
Auto-entreprise: Solutions informatiques sur mesure : http://www.info16.fr
Mon blog : http://blog.info16.fr
Image IPBImage IPBImage IPB

#9 TrashHard

TrashHard

    Membre avancé

  • Membres
  • 43 messages

Posté 01 avril 2011 - 08:53

Bonjour,

J'ai essayé d'effectuer les deux types d'opération sur ce topic et j'ai lu de nombreux topic sur le sujet ainsi que la doc (spécialement pour Klug) mais je comprend toujours pas cela ne fonctionne pas.

Je me retrouve avec ça lors du test:
Résultat du test check.AUTH_FAILED

Petite question sur un point qui me parait flou, Associer un identifiant (DN) : c'est bien pour l’identifiant admin de l'AD?
Zimbra 8.0.3 OSE
Ubuntu 12.4
Ad 2008R2

#10 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 4 926 messages
  • LocalisationPlanète Terre

Posté 01 avril 2011 - 09:58

Pas forcément l'admin de l'AD (et puis c'est pas bien d'utiliser ce compte) mais un compte de l'AD qui a des droits en lecture sur l'AD.
Guy Carré, professionel certifié de Zimbra, Contributeur Zimbra
tel : (+33) 2 47 66 60 11 / mail : guy@netixia.fr
https://myzimbra.net / http://www.yaziba.net / http://www.netixia.fr / http://blog.yaziba.net/

#11 TrashHard

TrashHard

    Membre avancé

  • Membres
  • 43 messages

Posté 01 avril 2011 - 10:08

Voir le messageZimbra Guy, le 01 avril 2011 - 09:58, dit :

Pas forcément l'admin de l'AD (et puis c'est pas bien d'utiliser ce compte) mais un compte de l'AD qui a des droits en lecture sur l'AD.

Justement on a créer un utilisateur zimbra juste pour ça mais vus que sa marche pas on fais des test avec l'admin et puis on essayeras plus tard avec un autre compte pour la mise en prod'

Bon je vais essayé de trouver mon erreur, merci pour ta réponse rapide :)
Zimbra 8.0.3 OSE
Ubuntu 12.4
Ad 2008R2

#12 Pro21

Pro21

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 522 messages

Posté 05 avril 2011 - 10:21

AD 2008 ?
dn -> Essaie avec compte@domain.tld ?
Zimbra 5.0.16 O.S.E/NE -> Zimbra 8 O.S.E/NE sur RHEL & CentOS
Serveurs physiques & Serveurs virtuels

#13 TrashHard

TrashHard

    Membre avancé

  • Membres
  • 43 messages

Posté 05 avril 2011 - 12:43

Voir le messagePro21, le 05 avril 2011 - 10:21, dit :

AD 2008 ?
dn -> Essaie avec compte@domain.tld ?


Ouaip c'est un AD 2008, mais depuis j'ai reformaté... et j'ai pas essayé de synchronisé, d'ailleurs je comprend pas le compte galsync@mondomaine.com se créer uniquement quand on créer un nouveau domaine ou il y a une manipulation à faire pour l'avoir? J'ai pas encore lu la doc sur ce sujet et je comprend pas tout donc ^^'

J'essayerais quand je retenterais le coup Pro21 merci du conseil  :)

[edit] : Sa à fonctionné sans le @domaine.tld
Zimbra 8.0.3 OSE
Ubuntu 12.4
Ad 2008R2

#14 Cedric H

Cedric H

    Membre

  • Membres
  • 15 messages

Posté 10 décembre 2015 - 17:15

Hello,

Comment faites-vous pour ne pas remonter aussi les utilisateurs "technique" qui ne possède aucune adresse email ?

Merci d'avance,

Cédric
Cédric H
Utilisateur de Zimbra et newbees en administration.
Version : 8.6.0_GA_1194.NETWORK + Zpush + Reverse Proxy

#15 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 4 926 messages
  • LocalisationPlanète Terre

Posté 11 décembre 2015 - 10:05

En utilisant les filtres de type LDAP.
Merci de mettre une signature dans tes posts.
Guy Carré, professionel certifié de Zimbra, Contributeur Zimbra
tel : (+33) 2 47 66 60 11 / mail : guy@netixia.fr
https://myzimbra.net / http://www.yaziba.net / http://www.netixia.fr / http://blog.yaziba.net/




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)