Aller au contenu


petit bug lors d'e l'interface de login


  • Veuillez vous connecter pour répondre
17 réponses à ce sujet

#1 produnet

produnet

    Membre expérimenté

  • Membres
  • PipPipPip
  • 376 messages
  • LocalisationGrenoble

Posté 15 mai 2020 - 14:18

Bonjour,

Il est possible de se logguer sur Zimbra uniquement sur une connexion HTTPS (sur HTTP il y a une erreur systématique liée aux cookies).

Qu'en pensez vous ?

zmcontrol -v
Release 8.8.15.GA.3869.UBUNTU18.64 UBUNTU18_64 FOSS edition, Patch 8.8.15_P9

Merci
SRV Debian 6 & 7 / Ubuntu LTS 14.4
Zimbra OSE 7 et 8 au bureau
Zimlets Asterisk

#2 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 766 messages
  • LocalisationPlanète Terre

Posté 15 mai 2020 - 14:30

Oui c'est possible.
L'erreur liée au cookie ce doit être parce que tu arrives en HTTP et que après tu es redirigé en HTTPS.
Vérifie le paramètre zimbraSSLUpstream

A+
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr
http://www.scalesi.fr/

#3 produnet

produnet

    Membre expérimenté

  • Membres
  • PipPipPip
  • 376 messages
  • LocalisationGrenoble

Posté 15 mai 2020 - 14:38

Merci de ta rapide réponse, lors de l'installation par défaut nous avons du coché zimbra-proxy, je souhaite le désactiver car je pense qu'il nous met le bazar notamment pour les paramètres "zimbraSSLUpstream" , est ce possible sans trop d'incidence le serveur est up !

merci
SRV Debian 6 & 7 / Ubuntu LTS 14.4
Zimbra OSE 7 et 8 au bureau
Zimlets Asterisk

#4 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 766 messages
  • LocalisationPlanète Terre

Posté 15 mai 2020 - 14:46

En 8, le proxy est obligatoire. Du moins son installation.
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr
http://www.scalesi.fr/

#5 produnet

produnet

    Membre expérimenté

  • Membres
  • PipPipPip
  • 376 messages
  • LocalisationGrenoble

Posté 15 mai 2020 - 15:07

Arff .... j'ai l'impression d'avoir pas mal de bugs lié à ce service proxy ...

1- problème ci dessus pas possible logguer en http
2- délai pour délivrer les mails environ 10 min
3- erreur dans le /vr/log/mail.log de type (Cannot start TLS: handshake failure)
SRV Debian 6 & 7 / Ubuntu LTS 14.4
Zimbra OSE 7 et 8 au bureau
Zimlets Asterisk

#6 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 766 messages
  • LocalisationPlanète Terre

Posté 15 mai 2020 - 15:40

Pour ton problème d'authentification HTTP essaie de mettre zimbraReverseProxySSLToUpstreamEnabled à FALSE si ce n'est pas le cas.
Ensuite pour ton MTA regarde plutôt dans /var/log/zimbra.log
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr
http://www.scalesi.fr/

#7 produnet

produnet

    Membre expérimenté

  • Membres
  • PipPipPip
  • 376 messages
  • LocalisationGrenoble

Posté 15 mai 2020 - 15:56

:D :D :D :D Merci Guy
Yes pour le problème authentification c'est ok ta manipzimbraReverseProxySSLToUpstreamEnabled a bien fonctionner au top merci.
Pour le MTA, rien à signaler dans le /var/log/zimbra.log

J'ai l'impression qu'il y a une espèce de Greylist, les mails partent avec du décalage quand il parte et l'interface graphique bug assez souvent avec ce genre de message d'erreur ...
method:    SaveDraftRequest msg:  
Une erreur réseau s’est produite.
code:    CSFE_SVC_ERROR detail:  
HTTP response status 502

En grattant un peu j'ai mis le parametre zimbraInvalidLoginFilterMaxFailedLogin à 0, ca a l'air de stabiliser

Merci
SRV Debian 6 & 7 / Ubuntu LTS 14.4
Zimbra OSE 7 et 8 au bureau
Zimlets Asterisk

#8 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 766 messages
  • LocalisationPlanète Terre

Posté 15 mai 2020 - 16:28

Le DosFilter peut-être ? Il faut Whitelister tes IP de ton ou tes serveurs si ce n'est pas le cas.
C'est ici que ça se passe : zimbraHttpThrottleSafeIPs , le mieux étant de mettre les réseaux sur lesquels évoluent tes serveurs.
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr
http://www.scalesi.fr/

#9 produnet

produnet

    Membre expérimenté

  • Membres
  • PipPipPip
  • 376 messages
  • LocalisationGrenoble

Posté 18 mai 2020 - 14:00

Bonjour,

Nous avons bien effectué le "whitelistage" des ip publique et local mais l'erreur revient toujours... par ailleurs, les mails peuvent mettre jusqu'à 10 minutes pour etre délivré.... une piste de recherche ?

Merci
SRV Debian 6 & 7 / Ubuntu LTS 14.4
Zimbra OSE 7 et 8 au bureau
Zimlets Asterisk

#10 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 766 messages
  • LocalisationPlanète Terre

Posté 18 mai 2020 - 16:13

Il faut regarder au moment du redémarrage du ou des mailboxd si les IP sont bien prise en compte. Si je me souviens bien le pattern c'est DosFilter qu'il faut prendre comme marqueur.
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr
http://www.scalesi.fr/

#11 produnet

produnet

    Membre expérimenté

  • Membres
  • PipPipPip
  • 376 messages
  • LocalisationGrenoble

Posté 19 mai 2020 - 04:35

Bonjour à tous,
J'ai bossé sur mon serveur grande partie de la nuit, sauvegarde, mise à jour ... ils me restent quelques coquilles assez embetante du surement à de mauvais reglages de ma part mais je galère.
Je pense que mon soucis se trouve au niveau des DNS et du dosfilter (comme Guy m'a donné la piste ci-dessus)
J'ai l'impression que tout fonctionne et d'un coup, il y a une coupure de service pendant quelques secondes, puis ca remarche... les mails mettent environ 6 minutes dans certains cas à être acheminer...

Voici un groupe de lignes qui reviennent régulièrement dans le /var/log/mail.log :
May 19 05:25:24 srv-ar /postfix-script[30950]: the Postfix mail system is running: PID: 21734
May 19 05:25:25 srv-ar postfix/submission/smtpd[23162]: warning: unknown[45.142.195.14]: SASL LOGIN authentication failed: authentication failure
May 19 05:25:28 srv-ar postfix/submission/smtpd[23162]: disconnect from unknown[45.142.195.14] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
May 19 05:25:38 srv-ar postfix/submission/smtpd[23162]: connect from unknown[45.142.195.14]
May 19 05:25:52 srv-ar postfix/submission/smtpd[23162]: warning: unknown[45.142.195.14]: SASL LOGIN authentication failed: authentication failure
May 19 05:25:55 srv-ar postfix/submission/smtpd[23162]: disconnect from unknown[45.142.195.14] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
May 19 05:26:05 srv-ar postfix/submission/smtpd[23162]: connect from unknown[45.142.195.14]

Je ne sais pas ce qu'est cette IP : 45.142.195.14

Par ailleurs, je me demande si mon /etc/hosts est bien configuré à force de faire des essais, qu'en pensez-vous :
127.0.0.1    localhost.localdomain localhost
#176.147.XXX.XX srv-ar.xxx.fr srv-ar
192.168.0.10    srv-ar.xxx.fr srv-ar

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback localhost
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
#ff02::1 ip6-allnodes
#ff02::2 ip6-allrouters

Idem voici les info /etc/network/interfaces :
auto lo
iface lo inet loopback

allow-hotplug eno1
iface eth0 inet static
address 192.168.0.10
netmask 255.255.255.0
gateway 192.168.0.254

#dns-nameservers 127.0.0.1
dns-nameservers 9.9.9.9
dns-nameservers 8.8.8.8
dns-nameservers 1.1.1.1

Et de mon /etc/resolv.conf :
search xxx.fr
nameserver 192.168.0.254
nameserver 9.9.9.9
nameserver 1.1.1.1

Par avance, merci à tous je galère ...

Merci
SRV Debian 6 & 7 / Ubuntu LTS 14.4
Zimbra OSE 7 et 8 au bureau
Zimlets Asterisk

#12 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 766 messages
  • LocalisationPlanète Terre

Posté 19 mai 2020 - 08:54

L'IP 45.142.195.14 est une IP qui fait du brute force.
Pour le reste il faut vérifier ta résolution DNS avec les outils nslookup ou dig.
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr
http://www.scalesi.fr/

#13 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 766 messages
  • LocalisationPlanète Terre

Posté 19 mai 2020 - 08:55

J'oubliais : regarde les paramètres du DNS cache de Zimbra.
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr
http://www.scalesi.fr/

#14 produnet

produnet

    Membre expérimenté

  • Membres
  • PipPipPip
  • 376 messages
  • LocalisationGrenoble

Posté 19 mai 2020 - 17:24

Grace à votre aide et surtout d'un bon pote (merci francky) je vous communique les différentes actions qui ont amélioré notre situation.

Réglages suivants :
zmprov ms `zmhostname` zimbraMtaLmtpTlsSecurityLevel none
Source : https://forums.zimbr...pic.php?t=60145

Règles Iptable :
iptables -t nat -A OUTPUT -p tcp -d 176.147.xxx.x -j DNAT --to-destination 192.168.x.x
pour que les connexions sortantes vers 176.147.xxx.x (ip externe), soit redirigé sur l'ip interne 192.168.x.x

Il me reste uniquement le problème d'erreur : mail.SEND_FAILURE qui revient aléatoirement...
(method: SaveDraftRequest msg:  
Une erreur réseau s’est produite.
code: CSFE_SVC_ERROR detail:  
HTTP response status 502)

Si vous avez des idées ???

Merci à tous
SRV Debian 6 & 7 / Ubuntu LTS 14.4
Zimbra OSE 7 et 8 au bureau
Zimlets Asterisk

#15 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 766 messages
  • LocalisationPlanète Terre

Posté 20 mai 2020 - 08:03

Il faut voir les logs au moment de l'erreur dans mailbox.log ou zmmailboxd.out
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr
http://www.scalesi.fr/

#16 produnet

produnet

    Membre expérimenté

  • Membres
  • PipPipPip
  • 376 messages
  • LocalisationGrenoble

Posté 28 mai 2020 - 18:18

Hello à tous,

Toujours e.....r avec cette erreur intempestive, j'ai stoppé les services dnscache avec un /opt/zimbra/bin/zmdnscachectl stop.

Mais toujours des bugs aléatoirement...

Voici le genre d'erreur que je trouve dans les logs zmmailboxd.out :

Caused by:
com.zimbra.common.service.ServiceException: no valid authtoken present|ExceptionId:qtp1427889191-39302://nom.domaine.fr/public/launchNewwindow.jsp???favIconUrl???:1590651126310:a68cbb6fb9ef686b|Code:service.AUTH_REQUIRED
    at com.zimbra.common.service.ServiceException.AUTH_REQUIRED(ServiceException.java:350)
    at com.zimbra.cs.taglib.ZJspSession.getZMailbox(ZJspSession.java:463)
    at com.zimbra.cs.taglib.tag.ZimbraSimpleTag.getMailbox(ZimbraSimpleTag.java:29)
    at com.zimbra.cs.taglib.tag.GetMailboxTag.doTag(GetMailboxTag.java:57)
    at org.apache.jsp.public_.launchNewWindow_jsp._jspService(launchNewWindow_jsp.java:220)
    at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
    at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:476)
    at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:386)
    at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:330)
    at org.eclipse.jetty.jsp.JettyJspServlet.service(JettyJspServlet.java:112)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
    at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:873)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1623)
    at org.eclipse.jetty.websocket.server.WebSocketUpgradeFilter.doFilter(WebSocketUpgradeFilter.java:214)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1610)
    at com.zimbra.cs.servlet.RequestStringFilter.doFilter(RequestStringFilter.java:54)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1610)
    at com.zimbra.webClient.filters.ForwardFilter.doFilter(ForwardFilter.java:88)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1610)
    at com.zimbra.cs.servlet.SetHeaderFilter.doFilter(SetHeaderFilter.java:59)
    at com.zimbra.webClient.filters.SetHeaderFilter.doFilter(SetHeaderFilter.java:248)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1610)
    at com.zimbra.cs.servlet.ContextPathBasedThreadPoolBalancerFilter.doFilter(ContextPathBasedThreadPoolBalancerFilter.java:107)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1610)
    at com.zimbra.cs.servlet.ZimbraQoSFilter.doFilter(ZimbraQoSFilter.java:116)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1610)
    at org.eclipse.jetty.servlets.DoSFilter.doFilterChain(DoSFilter.java:482)
    at org.eclipse.jetty.servlets.DoSFilter.doFilter(DoSFilter.java:327)
    at org.eclipse.jetty.servlets.DoSFilter.doFilter(DoSFilter.java:297)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1610)
    at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:540)
    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:146)
    at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:524)
    at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:132)
    at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle(ScopedHandler.java:257)
    at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:1700)
    at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle(ScopedHandler.java:255)
    at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1345)
    at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(ScopedHandler.java:203)
    at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:480)
    at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:1667)
    at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(ScopedHandler.java:201)
    at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1247)
    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:144)
    at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:220)
    at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:152)
    at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:132)
    at org.eclipse.jetty.rewrite.handler.RewriteHandler.handle(RewriteHandler.java:335)
    at org.eclipse.jetty.server.handler.gzip.GzipHandler.handle(GzipHandler.java:753)
    at org.eclipse.jetty.server.handler.DebugHandler.handle(DebugHandler.java:83)
    at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:132)
    at org.eclipse.jetty.server.Server.handle(Server.java:505)
    at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:370)
    at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:267)
    at org.eclipse.jetty.io.AbstractConnection$ReadCallback.succeeded(AbstractConnection.java:305)
    at org.eclipse.jetty.io.FillInterest.fillable(FillInterest.java:103)
    at org.eclipse.jetty.io.ChannelEndPoint$2.run(ChannelEndPoint.java:117)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.runTask(EatWhatYouKill.java:333)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.doProduce(EatWhatYouKill.java:310)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.tryProduce(EatWhatYouKill.java:168)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.run(EatWhatYouKill.java:126)
    at org.eclipse.jetty.util.thread.ReservedThreadExecutor$ReservedThread.run(ReservedThreadExecutor.java:366)
    at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:698)
    at org.eclipse.jetty.util.thread.QueuedThreadPool$Runner.run(QueuedThreadPool.java:804)
    at java.base/java.lang.Thread.run(Thread.java:830)

Voici le genre d'erreur que je trouve dans les logs mailbox.log (à la minute du plantage) :
2020-05-28 10:53:20,416 WARN  [qtp1427889191-39789://192.168.0.10/service/soap/SaveDraftRequest] [name=adresse@domaine.fr;mid=7;ip=192.168.0.10;port=42756;ua=ZimbraWebClient - FF76 (Win)/8.8.15_GA_3928;soapId=19121771;] SoapEngine - handler exception

Des idées ?

Merci
SRV Debian 6 & 7 / Ubuntu LTS 14.4
Zimbra OSE 7 et 8 au bureau
Zimlets Asterisk

#17 Klug

Klug

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 10 461 messages
  • LocalisationPlaisians - Drôme

Posté 16 juin 2020 - 14:48

Il est nickel chrome ton SplitDNS ?
Les variable ZimbraPublicService sont bien renseignées pour ton domaine ?

#18 produnet

produnet

    Membre expérimenté

  • Membres
  • PipPipPip
  • 376 messages
  • LocalisationGrenoble

Posté 16 septembre 2020 - 06:41

Bonjour à tous,

Je pense que mon SplitDns est ok mais comment vérifier ?
J'ai toujours des erreurs aléatoires dans la journée : system failure: Unable to send message puis on reclique sur envoi et ca passe...

Merci
SRV Debian 6 & 7 / Ubuntu LTS 14.4
Zimbra OSE 7 et 8 au bureau
Zimlets Asterisk




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)