Aller au contenu


Problème de stabilité zimbra, cron ? (zimbra) DELETE (zimbra)


  • Veuillez vous connecter pour répondre
3 réponses à ce sujet

#1 max2france

max2france

    Membre

  • Membres
  • 27 messages

Posté 03 mai 2019 - 10:15

Bonjour,

Je dispose d'un serveur zimbra 8.6.x OSE qui fonctionner bien sauf que la j'ai un problème dont je n'arrive pas à trouver l'origine.

Je sollicite donc vos avis, expérience.

Tous les services sont en running:
Host webmail.ems-app.com
		amavis				  Running
		antispam				Running
		antivirus			   Running
		dnscache				Running
		ldap					Running
		logger				  Running
		mailbox				 Running
		memcached			   Running
		mta					 Running
		opendkim				Running
		proxy				   Running
		service webapp		  Running
		snmp					Running
		spell				   Running
		stats				   Running
		zimbra webapp		   Running
		zimbraAdmin webapp	  Running
		zimlet webapp		   Running
		zmconfigd			   Running

Il fonctionne parfaitement et quasiment chaque matin depuis quelques jours, j'ai un soucis (entre 6 et 9H environ), plusieurs services ne fonctionnent plus.

Je retrouve le serveur comme ca :

  
  amavis				  Stopped
				amavisd is running.
				amavisd-mc is not running.
		antispam				Stopped
				zmamavisdctl is not running
		antivirus			   Stopped
				zmamavisdctl is not running
		dnscache				Running
		ldap					Running
		logger				  Running
		mailbox				 Stopped
				zmmailboxdctl is not running.
		memcached			   Running
		mta					 Running
		opendkim				Running
		proxy				   Running
		service webapp		  Stopped
				zmmailboxdctl is not running.
		snmp					Stopped
				zmswatch is not running.
		spell				   Running
		stats				   Stopped
		zimbra webapp		   Stopped
				zmmailboxdctl is not running.
		zimbraAdmin webapp	  Stopped
				zmmailboxdctl is not running.
		zimlet webapp		   Stopped
				zmmailboxdctl is not running.
		zmconfigd			   Running

Je dois tout couper plusieurs fois, voir faire des kill pour tout arriver et j'arrive à faire mon zmcontrol start


J'ai fais pas mal de recherche pour chercher à comprendre et la seule chose que j'ai constaté par 3 fois qu'au moment, le problème j'avais ceci dans les logs CRON :

<(zimbra) DELETE (zimbra) & (zimbra) LIST (zimbra)>

May  3 06:01:01 webmail CROND[25866]: (root) CMD (run-parts /etc/cron.hourly)
May  3 06:01:01 webmail run-parts(/etc/cron.hourly)[25866]: starting 0anacron
May  3 06:01:01 webmail run-parts(/etc/cron.hourly)[25875]: finished 0anacron
May  3 06:01:01 webmail run-parts(/etc/cron.hourly)[25866]: starting mcelog.cron
May  3 06:01:01 webmail run-parts(/etc/cron.hourly)[25894]: finished mcelog.cron
May  3 06:10:01 webmail CROND[30336]: (root) CMD (/usr/lib64/sa/sa1 1 1)
May  3 06:20:01 webmail CROND[35165]: (root) CMD (/usr/lib64/sa/sa1 1 1)
May  3 06:28:40 webmail crontab[39743]: (zimbra) DELETE (zimbra)
May  3 06:28:41 webmail crontab[39789]: (zimbra) LIST (zimbra)
May  3 06:28:41 webmail crontab[39791]: (zimbra) DELETE (zimbra)
May  3 06:28:41 webmail crontab[39792]: (zimbra) LIST (zimbra)
May  3 06:28:41 webmail crontab[39794]: (zimbra) DELETE (zimbra)
May  3 06:28:41 webmail crontab[39795]: (zimbra) LIST (zimbra)
May  3 06:28:41 webmail crontab[39797]: (zimbra) DELETE (zimbra)
May  3 06:28:41 webmail crontab[39800]: (zimbra) DELETE (zimbra)
May  3 06:28:41 webmail crontab[39798]: (zimbra) LIST (zimbra)
May  3 06:28:41 webmail crontab[39801]: (zimbra) LIST (zimbra)
May  3 06:28:41 webmail crontab[39803]: (zimbra) DELETE (zimbra)
May  3 06:28:41 webmail crontab[39804]: (zimbra) LIST (zimbra)
May  3 06:28:41 webmail crontab[39806]: (zimbra) DELETE (zimbra)
May  3 06:28:41 webmail crontab[39807]: (zimbra) LIST (zimbra)
May  3 06:28:41 webmail crontab[39809]: (zimbra) DELETE (zimbra)
May  3 06:28:41 webmail crontab[39810]: (zimbra) LIST (zimbra)
May  3 06:28:41 webmail crontab[39812]: (zimbra) DELETE (zimbra)
May  3 06:28:41 webmail crontab[39813]: (zimbra) LIST (zimbra)
May  3 06:28:41 webmail crontab[39815]: (zimbra) DELETE (zimbra)
May  3 06:28:41 webmail crontab[39816]: (zimbra) LIST (zimbra)

Avez-vous une idée de quel cron? service ? viens ces commandes qui tournent en boucle dès le plantage ? DELETE (zimbra) LIST ?

Je pense donc que cela viens des crons.

Quelqu'un a déjà eu cela?

Merci par avance pour votre aide.
Version 8.6.0_GA_1153.FOSS / Centos 6.7

#2 Klug

Klug

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 10 375 messages
  • LocalisationBeaucaire - Gard

Posté 03 mai 2019 - 11:12

Je pense que le serveur n'est pas patché et les failles XXE ont été utilisées.

https://www.zimbrafr...-important-xxe/

https://forums.zimbr...hp?f=15&t=65932
https://forums.zimbr...hp?f=15&t=66092

Il faut regarder le contenu de la crontab (du user zimbra), ça donne de suite une bonne idée.
Pour beaucoup de gens (voir thread US), il y a une ligne ajoutée.
Mais j'ai également vu une crontab complètement vidée il y a deux jours (sur un serveur qui n'est que mailstore).

#3 max2france

max2france

    Membre

  • Membres
  • 27 messages

Posté 04 mai 2019 - 05:50

Merci pour ton retour, j'ai mis à jour avec le dernier patch
j'ai mis a jour 8.6.0P14 pour le moment

Mon zimbra est ok (envoi/reception/api) par contre j'ai un soucis avec la partie zimbraAdmin.

J'arrive bien à me logguer mais j'ai une erreur récurrente sur l'interface

Erreur de Javascript in methode
ZaOverviewPanelController.prototype._overviewTreeListener

Avez-vous déjà eu ça ?

Merci pour votre aide
Version 8.6.0_GA_1153.FOSS / Centos 6.7

#4 Klug

Klug

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 10 375 messages
  • LocalisationBeaucaire - Gard

Posté 04 mai 2019 - 10:18

Il faut nettoyer en plus de juste mettre à jour.

L'erreur ne me dit rien.
Tu n'aurais pas supprimé des fichiers dont l'interface a besoin ?




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)