Aller au contenu


reverse dns avec multi domaine


  • Veuillez vous connecter pour répondre
11 réponses à ce sujet

#1 c.mutz

c.mutz

    Membre

  • Membres
  • 17 messages

Posté 25 avril 2019 - 14:15

Bonjour à tous !

Depuis quelques temps déjà, nous nous faisons refuser pas mal de mails à cause du reverse DNS.

host relay1[x.x.x.x]
    said: 550 5.7.1 Client host rejected: cannot find your reverse hostname,
    [MON_IP_PUNLIC] (in reply to RCPT TO command)

Nous avons un zimbra avec 5 domaines différents (domaine A, domaine B, domaine C ...).
Si j'envoi un mail depuis le domaine B ou C le domaine du relay dans le mail sera toujours le domaine A, donc certains relais nous refusent...

J'ai vu que l'on pouvait faire du multi certificats https://wiki.zimbra....ates_per_domain
Est ce que c'est la seule solution pour résoudre mon problème ?

Merci d'avance.

Clément.

p.s : j'ai peut être du mal à exprimer mon soucis, donc si c'est le cas n'hésitez pas à poser des questions ;)
version de zimbra utilisé : Zimbra 8.8.12_GA_3794 (build 20190329045002)
configuration software : Ubuntu 16.04
configuration matériel : 10Vcpu et 16GB de ram

#2 wolfy

wolfy

    Zimbra Jedi

  • Modérateurs
  • 550 messages
  • LocalisationRouen, France

Posté 25 avril 2019 - 14:32

here you go => https://wiki.zimbra...._and_DMARC#rDNS
___
Senior Solution Advisor EMEA chez Vade Secure

#3 Klug

Klug

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 10 374 messages
  • LocalisationBeaucaire - Gard

Posté 25 avril 2019 - 15:04

AMHA, le problème n'est pas lié au fait que vous ayez plusieurs domaines.
Par contre, avoir un reverse inexistant ou faux, c'est possible.

#4 c.mutz

c.mutz

    Membre

  • Membres
  • 17 messages

Posté 26 avril 2019 - 09:21

Bonjour et merci pour vos réponse.

Actuellement le domaine A pointe vers l'adresse ip du serveur de mail.
Mais lorsque j'envoi des mails depuis le domaine B ou C certains mails sont refuses par quelques serveurs de mails du fait que le reverse dns correspond au domaine A.

Comment faites-vous de votre côté lorsque vous devez gérer plusieurs domaines sur un même serveur (j'ai la possibilité d'ajouter des adresse ip publiques supplémentaires si il le faut) ?
J'ai vu ce lien https://wiki.zimbra....(SNI)_for_HTTPS qui parle du multi certificats pour plusieurs domaines mais je ne sais pas si cela correspond reellement à mes besoins...

Merci d'avance

Clement
version de zimbra utilisé : Zimbra 8.8.12_GA_3794 (build 20190329045002)
configuration software : Ubuntu 16.04
configuration matériel : 10Vcpu et 16GB de ram

#5 c.mutz

c.mutz

    Membre

  • Membres
  • 17 messages

Posté 26 avril 2019 - 09:28

Pour préciser un peu mon problème voici un extrait de mail envoyé depuis le domaine B

ARC-Authentication-Results: i=1; mx.google.com;
       dkim=pass header.i=@DOMAINE_B header.s=B59B2A4A-06CC-11E8-9661-D2A200224F40 header.b=K0Tz9nds;
       spf=pass (google.com: domain of ****@DOMAINE_B designates IP_PUBLIC_SERVEUR_MAIL as permitted sender) smtp.mailfrom=****@DOMAINE_B;
       dmarc=pass (p=QUARANTINE sp=REJECT dis=NONE) header.from=DOMAINE_B
Return-Path: <****@DOMAINE_B>

Received: from mail.DOMAINE_A (mail.DOMAINE_A. [IP_PUBLIC_SERVEUR_MAIL])
        by mx.google.com with ESMTPS id g130si17262584wmf.140.2019.04.26.01.10.17
        for <*****@gmail.com>

Merci d'avance
version de zimbra utilisé : Zimbra 8.8.12_GA_3794 (build 20190329045002)
configuration software : Ubuntu 16.04
configuration matériel : 10Vcpu et 16GB de ram

#6 Klug

Klug

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 10 374 messages
  • LocalisationBeaucaire - Gard

Posté 26 avril 2019 - 10:39

Je me répète : ça fonctionne parfaitement (et heureusement) sans configuration particulière (tant qu'on fait du SMTP de base).

Dans le dernier post, les headers semblent bons et montrent que le mail est accepté (avec du SPF et du DKIM en plus).
Dans le premier post, l'erreur c'est la résolution du reverse qui ne s'effectue pas.

I'm feeling lucky: https://www.kreativm...t-host-rejected

#7 c.mutz

c.mutz

    Membre

  • Membres
  • 17 messages

Posté 26 avril 2019 - 12:06

Voir le messageKlug, le 26 avril 2019 - 10:39, dit :

Je me répète : ça fonctionne parfaitement (et heureusement) sans configuration particulière (tant qu'on fait du SMTP de base).

Dans le dernier post, les headers semblent bons et montrent que le mail est accepté (avec du SPF et du DKIM en plus).
Dans le premier post, l'erreur c'est la résolution du reverse qui ne s'effectue pas.

I'm feeling lucky: https://www.kreativm...t-host-rejected

Désolé Klug, Je me suis mal exprimé !
Ce que je voulais dire c'est que je ne comprends pas c'est ce genre de message d'erreur "reverse DNS inexistant" alors que justement j'ai un enregistrement PTR pour cette adresse ip.

Le temps du post je te donne l'adresse ip en question (62.4.29.136)
lorsque je fais un nslookup j'ai cette réponse :

`--# nslookup 62.4.29.136
136.29.4.62.in-addr.arpa		canonical name = 136.128-27.29.4.62.in-addr.arpa.
136.128-27.29.4.62.in-addr.arpa name = mail.universals.email.
Authoritative answers can be found from:

Je vais refaire un essai à cas où pour voir si c'est résolu sachant que l'enregistrement PTR existe depuis toujours.


Plus haut Klug tu as parlé d'avoir un reverse faux, que veux-tu dire par là?

Merci

Clément
version de zimbra utilisé : Zimbra 8.8.12_GA_3794 (build 20190329045002)
configuration software : Ubuntu 16.04
configuration matériel : 10Vcpu et 16GB de ram

#8 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 499 messages
  • LocalisationPlanète Terre

Posté 26 avril 2019 - 15:06

Bonjour,

l'enregistrement n'est pas conforme à mon avis.
nslookup devrait renvoyer
136.29.4.62.in-addr.arpa      name = mail.universals.email.

Cordialement,
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr

#9 Klug

Klug

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 10 374 messages
  • LocalisationBeaucaire - Gard

Posté 27 avril 2019 - 10:52

$ nslookup 62.4.29.136
Server:		 127.0.0.1
Address:		127.0.0.1#53

** server can't find 136.29.4.62.in-addr.arpa.: NXDOMAIN

Ça marche pas des masses je trouve...

En utilisant DNSStuff, ce serait nsa.online.net qui gère la zone reverse.
Pourquoi il ne me répond pas quand je l'interroge via un Unbound ? Aucune idée.
Mais il n'y a pas qu'à moi qu'il ne répond pas.

#10 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 499 messages
  • LocalisationPlanète Terre

Posté 27 avril 2019 - 19:17

@Klug :  effectivement il n'y a plus de réponse sur l'IP
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr

#11 c.mutz

c.mutz

    Membre

  • Membres
  • 17 messages

Posté 29 avril 2019 - 08:57

Voir le messageKlug, le 27 avril 2019 - 10:52, dit :

$ nslookup 62.4.29.136
Server:		 127.0.0.1
Address:	 127.0.0.1#53

** server can't find 136.29.4.62.in-addr.arpa.: NXDOMAIN

Ça marche pas des masses je trouve...

En utilisant DNSStuff, ce serait nsa.online.net qui gère la zone reverse.
Pourquoi il ne me répond pas quand je l'interroge via un Unbound ? Aucune idée.
Mais il n'y a pas qu'à moi qu'il ne répond pas.

Oui j'ai laissé ce week-end le serveur DNS (bind9) dans une situation sans rDNS (à force de bidouiller...)
Du coup si tu refais un nslookup tu auras la réponse suivante.

Citation

`--# nslookup 62.4.29.136
136.29.4.62.IN-ADDR.ARPA canonical name = 136.128-27.29.4.62.in-addr.arpa.
136.128-27.29.4.62.IN-ADDR.ARPA name = mail.ncs-france.fr.

Authoritative answers can be found from:

Bon d'après @Zimbra Guy le format n'est pas bon. Je vais essayer de trouver une solution.

Sur les différents sites de test (ex : https://www.mail-tester.com/test-8b2ab) le résultat est plus correct (du moins me semble t-il :) )

Merci,
version de zimbra utilisé : Zimbra 8.8.12_GA_3794 (build 20190329045002)
configuration software : Ubuntu 16.04
configuration matériel : 10Vcpu et 16GB de ram

#12 Klug

Klug

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 10 374 messages
  • LocalisationBeaucaire - Gard

Posté 29 avril 2019 - 18:43

Ça marche ça, j'ai un subnet comme ça et sans problème (un /29 délégué de cette manière depuis l'opérateur).




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)