Aller au contenu


Installation difficile : 8.8.12 sur Ubuntu 18.04


  • Veuillez vous connecter pour répondre
5 réponses à ce sujet

#1 TheFurax

TheFurax

    Nouveau membre

  • Membres
  • 3 messages

Posté 17 avril 2019 - 14:52

Hello,

Je suis un grand débutant sur Zimbra, je suis en recherche d'une solution de remplacement à un bête serveur Postfix / dovecot qui est lourd de configuration dés qu'un soucis se présente et sans interface web c'est un peu ... lourd :)

Je me tourne vers vous après une douzaine d'heure passé à chercher une solution à mon problème qui est le suivant :

Mon proxy ne parvient pas à démarrer :/ :

zimbra@mail:~/log$ zmproxyctl start
Starting proxy...nginx: [emerg] unknown directive "zmauth_zx" in /opt/zimbra/conf/nginx/includes/nginx.conf.web:66
failed.

Les lignes incriminés sont les suivante :
#  Define the collection of upstream HTTP servers to dedicated zx port of jetty
    upstream zx
    {
    server    mail.thefurax.ovh:8742 fail_timeout=10s version=8.8.12_GA_3794;

==>zmauth_zx;
    }

    #  Define the collection of upstream HTTPS servers to dedicated zx ssl port of jetty
    upstream zx_ssl
    {
    server    mail.thefurax.ovh:8743 fail_timeout=10s version=8.8.12_GA_3794;

    zmauth_zx;
    }

Également, j'ai des processus zmstat qui consomme l'entièreté de mon CPU :

zimbra   19523 89.8  0.0  38508  1528 pts/0    R    05:28 451:04 /usr/bin/perl -w /opt/zimbra/libexec/zmstat-io -x
zimbra   19525  0.0  0.1  38756  3708 pts/0    S    05:28   0:00 /usr/bin/perl -w /opt/zimbra/libexec/zmstat-df
zimbra   19527 89.9  0.0  38500  1504 pts/0    R    05:28 451:24 /usr/bin/perl -w /opt/zimbra/libexec/zmstat-io


Concernant le setup effectué il est avec un NAT et une IP Virtuelle au niveau du PFSense en frontend.

Je suis un peu à court de solution et reste bien entendu à votre disposition pour des renseignement complémentaire.

#2 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 454 messages
  • LocalisationPlanète Terre

Posté 17 avril 2019 - 15:50

Bonjour,

as-tu un DNS interne ?

  Cordialement,
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr

#3 TheFurax

TheFurax

    Nouveau membre

  • Membres
  • 3 messages

Posté 17 avril 2019 - 16:20

Bonjour,

Merci pour ce retour ultra rapide ;)

J'ai effectivement configuré dnsmasq à l'aide la documentation suivante :
https://wiki.zimbra....e_Zimbra_Server
root@mail:/var/log# cat /etc/hosts
10.0.2.54 mail.thefurax.ovh mail
127.0.0.1	   localhost.localdomain   localhost
root@mail:/var/log# cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#	 DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "systemd-resolve --status" to see details about the actual nameservers.
nameserver 127.0.0.1
search thefurax.ovh


#4 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 454 messages
  • LocalisationPlanète Terre

Posté 17 avril 2019 - 16:57

OK je pense comprendre.
Il semblerait que cela soit lié à des modules Zextra.
Je t'invite à mettre dans un premier temps les blocs correspondants à zmauth_zx, dans les templates nginx, en commentaire.
Ensuite tu redémarres le service proxy zimbra.
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr

#5 TheFurax

TheFurax

    Nouveau membre

  • Membres
  • 3 messages

Posté 17 avril 2019 - 17:52

Hello,

J'ai tenter de commenter dans les templates :
zimbra@mail:~/conf/nginx/templates$ zmproxyctl start
Starting proxy...nginx: [emerg] host not found in upstream "zx_ssl" in /opt/zimbra/conf/nginx/includes/nginx.conf.web.https.default:237
failed.

J'ai commenter de nouveau élément dans le https default et surprise le service proxy a démarrer correctement :)

Avant j'avais effectivement un message d'erreur pour le tchat cela n'est plus présent.

Par contre l'erreur de consommation CPU par les tâches cités au début :

Citation

Également, j'ai des processus zmstat qui consomme l'entièreté de mon CPU :

zimbra   19523 89.8  0.0  38508  1528 pts/0 R 05:28 451:04 /usr/bin/perl -w /opt/zimbra/libexec/zmstat-io -x
zimbra   19525  0.0  0.1  38756  3708 pts/0 S 05:28   0:00 /usr/bin/perl -w /opt/zimbra/libexec/zmstat-df
zimbra   19527 89.9  0.0  38500  1504 pts/0 R 05:28 451:24 /usr/bin/perl -w /opt/zimbra/libexec/zmstat-io

Son toujours présente et m'empêche l'accès aux statistiques du panneau admin, je continue d'investiguer pour l'instant sans succès.

J'ai bien le fichier : /opt/zimbra/zmstat/zmstat.out
Qui contient quelque millions (oui au moins) de fois cette ligne :
Use of uninitialized value $line in pattern match (m//) at /opt/zimbra/libexec/zmstat-io line 76.

J'ai modifier le fichier /opt/zimbra/libexec/zmstat-io pour y adjoindre :
no warnings 'uninitialized';

Le processus génère toujours autant d'utilisation CPU mais au moins ne me remplis pas le disque à la vitesse de la lumière (en toute relativité s'agissant d'un 7200RPM Sata :D)

#6 Klug

Klug

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 10 358 messages
  • LocalisationBeaucaire - Gard

Posté 17 avril 2019 - 20:52

Nan mais c'est beta.

La première chose à faire, c'est lire les releases notes.
Le support d'Ubuntu 18.04 est beta.
Si on veut installer son premier Zimbra (ça marche aussi avec d'autres produits), on ne le fait pas avec avec un support d'OS en "beta".

Il a un thread sur le forum US.




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)