Aller au contenu


Pieces jointes sur smartphone mais pas sur le webmail


  • Veuillez vous connecter pour répondre
7 réponses à ce sujet

#1 k-one

k-one

    Membre

  • Membres
  • 11 messages

Posté 20 mars 2019 - 09:39

Bonjour,

Je rencontre un pb assez bizard avec mon serveur Zimbra OSE en 8.8.11 GA_3772 sur une centos 7.6.1810.

Pour certains mails les pièces jointes arrivent bien sur le smartphone mais pas sur le webmail.

Un client/fournisseur X envoi un mail avec une pièce jointe à Mr Y de ma boite. Mr Y voit la pièce jointe sur son téléphone mais pas sur le webmail.
Quand il se transfert le mail à lui même de son téléphone vers sa boite mail = idem
Quand il se transfert le mail vers une boite gmail/orange autre etc = pas de soucis la pièce jointe est bien là.

Dans le mail il y a une image tiff de signature, si je la supprime lors du transfert depuis le smartphone vers la boite de mr Y la piece jointe arrive sans pb.....


Cela se produit peut importe le domaine expéditeur et aléatoirement car pour la grande majorité des mails entrants avec pj pas de soucis.

J'ai cherché dans les logs mailbox, amavis, trace etc.. je ne vois rien d'anormal.

Côté parefeu j'ai un watchguard et j'ai tracé les mails tout est ok. aucuns blocages.


Avez-vous déjà rencontré le même pb ?

Merci de votre aide
RSI dans une société de 100 personnes
ZIMBRA OSE 8.8.11 GA_3772  installé sur une vm centOS >> 7.6.1810

#2 k-one

k-one

    Membre

  • Membres
  • 11 messages

Posté 20 mars 2019 - 09:46

Voici le log du message envoyé depuis un smartphone vers sa propre boite mail :
Mar 20 09:44:16 tityos postfix/smtpd[31969]: NOQUEUE: filter: RCPT from tityos.tpa.int[192.168.69.242]: <email@expediteur.com>: Sender address triggers FILTER smtp-amavis:[127.0.0.1]:10026; from=<email@expediteur.com> to=<email@destinataire.com> proto=ESMTP helo=<tityos.tpa.int>
Mar 20 09:44:16 tityos postfix/smtpd[31969]: 973CB9028F5: client=tityos.tpa.int[192.168.69.242]
Mar 20 09:44:16 tityos postfix/cleanup[31972]: 973CB9028F5: message-id=<1843655566.8449.1553071456523.JavaMail.zimbra@tityos.tpa.int>
Mar 20 09:44:16 tityos postfix/smtpd[31969]: disconnect from tityos.tpa.int[192.168.69.242] ehlo=1 mail=1 rcpt=1 data=1 quit=1 commands=5
Mar 20 09:44:16 tityos postfix/qmgr[31992]: 973CB9028F5: from=<email@expediteur.com>, size=577041, nrcpt=1 (queue active)
Mar 20 09:44:16 tityos amavis[31689]: (31689-16) ESMTP :10026 /opt/zimbra/data/amavisd/tmp/amavis-20190320T084459-31689-Zeg2Vf7o: <email@expediteur.com> -> <email@destinataire.com> Received: from tityos.tpa.int ([127.0.0.1]) by localhost (tityos.tpa.int [127.0.0.1]) (amavisd-new, port 10026) with ESMTP for <email@destinataire.com>; Wed, 20 Mar 2019 09:44:16 +0100 (CET)
Mar 20 09:44:16 tityos amavis[31689]: (31689-16) Checking: T1ZPnB63_sIN ORIGINATING/MYNETS [192.168.69.242] <email@expediteur.com> -> <email@destinataire.com>
Mar 20 09:44:16 tityos postfix/dkimmilter/smtpd[29250]: connect from localhost.localdomain[127.0.0.1]
Mar 20 09:44:16 tityos postfix/dkimmilter/smtpd[29250]: C9BAC9028F9: client=localhost.localdomain[127.0.0.1]
Mar 20 09:44:16 tityos postfix/cleanup[4844]: C9BAC9028F9: message-id=<1843655566.8449.1553071456523.JavaMail.zimbra@tityos.tpa.int>
Mar 20 09:44:16 tityos opendkim[31726]: C9BAC9028F9: no signing table match for 'email@expediteur.com'
Mar 20 09:44:16 tityos postfix/dkimmilter/smtpd[29250]: disconnect from localhost.localdomain[127.0.0.1] ehlo=1 mail=1 rcpt=1 data=1 quit=1 commands=5
Mar 20 09:44:16 tityos amavis[31689]: (31689-16) T1ZPnB63_sIN FWD from <email@expediteur.com> -> <email@destinataire.com>, BODY=7BIT 250 2.0.0 from MTA(smtp:[127.0.0.1]:10030): 250 2.0.0 Ok: queued as C9BAC9028F9
Mar 20 09:44:16 tityos postfix/qmgr[31992]: C9BAC9028F9: from=<email@expediteur.com>, size=577499, nrcpt=1 (queue active)
Mar 20 09:44:16 tityos amavis[31689]: (31689-16) Passed CLEAN {RelayedInternal}, ORIGINATING/MYNETS LOCAL [192.168.69.242]:57378 <email@expediteur.com> -> <email@destinataire.com>, Queue-ID: 973CB9028F5, Message-ID: <1843655566.8449.1553071456523.JavaMail.zimbra@tityos.tpa.int>, mail_id: T1ZPnB63_sIN, Hits: -, size: 577040, queued_as: C9BAC9028F9, 235 ms
Mar 20 09:44:16 tityos postfix/smtp[25598]: 973CB9028F5: to=<email@destinataire.com>, relay=127.0.0.1[127.0.0.1]:10026, delay=0.28, delays=0.04/0/0/0.23, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10030): 250 2.0.0 Ok: queued as C9BAC9028F9)
Mar 20 09:44:16 tityos postfix/qmgr[31992]: 973CB9028F5: removed
Mar 20 09:44:16 tityos postfix/amavisd/smtpd[4846]: connect from localhost.localdomain[127.0.0.1]
Mar 20 09:44:16 tityos postfix/amavisd/smtpd[4846]: Anonymous TLS connection established from localhost.localdomain[127.0.0.1]: TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)
Mar 20 09:44:16 tityos postfix/amavisd/smtpd[4846]: DD2039028F5: client=localhost.localdomain[127.0.0.1]
Mar 20 09:44:16 tityos postfix/cleanup[31972]: DD2039028F5: message-id=<1843655566.8449.1553071456523.JavaMail.zimbra@tityos.tpa.int>
Mar 20 09:44:16 tityos postfix/smtp[29252]: C9BAC9028F9: to=<email@destinataire.com>, relay=127.0.0.1[127.0.0.1]:10025, delay=0.14, delays=0.06/0.01/0/0.06, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as DD2039028F5)
Mar 20 09:44:16 tityos postfix/amavisd/smtpd[4846]: disconnect from localhost.localdomain[127.0.0.1] ehlo=2 starttls=1 mail=1 rcpt=1 data=1 quit=1 commands=7
Mar 20 09:44:16 tityos postfix/qmgr[31992]: DD2039028F5: from=<email@expediteur.com>, size=577670, nrcpt=1 (queue active)
Mar 20 09:44:16 tityos postfix/qmgr[31992]: C9BAC9028F9: removed
Mar 20 09:44:17 tityos postfix/lmtp[28444]: DD2039028F5: to=<email@destinataire.com>, relay=tityos.tpa.int[192.168.69.242]:7025, delay=0.24, delays=0.06/0.01/0.06/0.12, dsn=2.1.5, status=sent (250 2.1.5 Delivery OK)
Mar 20 09:44:17 tityos postfix/qmgr[31992]: DD2039028F5: removed
RSI dans une société de 100 personnes
ZIMBRA OSE 8.8.11 GA_3772  installé sur une vm centOS >> 7.6.1810

#3 Klug

Klug

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 10 375 messages
  • LocalisationBeaucaire - Gard

Posté 20 mars 2019 - 13:05

Ce ne sont pas des fichiers joints "inline" envoyés par Apple Mail ?

#4 k-one

k-one

    Membre

  • Membres
  • 11 messages

Posté 20 mars 2019 - 14:00

Bonjour,

Je ne connais pas le moyen utilisé par mes clients pour envoyer les fameux mails.

J'ai fais le test avec un smartphone huawei android et depuis gmail pas de soucis de piece jointe.


Ce qui est bizard c'est que c'est aléatoire, et que si j’enlève la pièce jointe (signature) .tiff ou png dans certain cas et que je re-transfert le mail sur lui même la pièce jointe pdf apparaît dans le webmail.

Y'a t-il un endroit dans les logs ou l'on peut voir les pièces jointes attachées au mail ?


Quel serait la cause de ces fameux fichiers joints "inline" envoyés par Apple Mail ?


Merci
RSI dans une société de 100 personnes
ZIMBRA OSE 8.8.11 GA_3772  installé sur une vm centOS >> 7.6.1810

#5 k-one

k-one

    Membre

  • Membres
  • 11 messages

Posté 20 mars 2019 - 14:57

Klug,

apparement le problème est bien celui que tu cites.

Je viens de tomber sur un post dans le forum zimbra qui dit ceci :

Il parle d'un code a utiliser saurais-tu me dire comment l'appliquer stp ?

curl -L 'https://bugzilla.zim...nt.cgi?id=68206' | bash

***********************************

Hi folks,

TL;DR: This is a regression from 8.8.10 to 8.8.11. To work around this issue, apply the following script from Select allcurl -L 'https://bugzilla.zim...nt.cgi?id=68206' | bash


If you've updated to 8.8.11 you might notice after a while that the Web UI doesn't display PDF attachments anymore if the mail was sent via Apple Mail. It looks like some brilliant mind at Apple thought it was a good idea to send all PDF files as "inline" content instead of "attachment" content. This happens for a while now but in 8.8.11 a script will revert this change until the issue is fixed properly.
RSI dans une société de 100 personnes
ZIMBRA OSE 8.8.11 GA_3772  installé sur une vm centOS >> 7.6.1810

#6 Klug

Klug

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 10 375 messages
  • LocalisationBeaucaire - Gard

Posté 20 mars 2019 - 17:29

Le correctif est intégré dans le dernier patch.
Qu'il faut absolument passer pour d'autres raisons...

#7 k-one

k-one

    Membre

  • Membres
  • 11 messages

Posté 21 mars 2019 - 07:32

Super merci beaucoup.

J'ai beau chercher je ne trouve pas de procédure pour installer ce patch.
Je ne suis pas super familier avec l'administration de zimbra (installation et mise à jour), c'est une tache que je délègue généralement a mon presta mais celui-ci est indispo pour le moment. S'il est simple de le faire je veux bien m'y risquer en hno en faisant un snapshot et un backup full veeam au préalable.

J'ai regardé la doc admin zimbra et je ne trouve pas non plus.

Je ferai un arrêt des services zimbra :
su zimbra > zmcontrol stop
retour en root > decompression du tgz dans le /tmp
puis je lance le script ./install.sh ?

et enfin redémarrage des services zimbra.

est-ce bien la procédure ou j'oubli une étape ?

De plus en faisant un zmcontrol -v j'ai ceci :
Release 8.8.11_GA_3737.RHEL7_64_20181207111719 RHEL7_64 FOSS edition, Patch 8.8.11_P2

C'est bien ce patch là qu'il faut installer >> zcs-8.8.11_GA_3737.RHEL7_64.20181207111719.tgz ?


Merci Klug pour tes réponses et ton aide.
RSI dans une société de 100 personnes
ZIMBRA OSE 8.8.11 GA_3772  installé sur une vm centOS >> 7.6.1810

#8 Klug

Klug

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 10 375 messages
  • LocalisationBeaucaire - Gard

Posté 21 mars 2019 - 11:03

Faut booster le presta, le passage de ce patch est vraiment TRES important.

https://www.zimbrafr...-important-xxe/

Dans le post que j'ai fait (lien ci-dessus), il y a les informations sur "comment passer un patch en fonction de l'OS".
Ça se passe via le système de packages de l'OS en 8.8.récente.




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)