Aller au contenu


Content-Transfer-Encoding Transformé


  • Veuillez vous connecter pour répondre
2 réponses à ce sujet

#1 DJeremy

DJeremy

    Nouveau membre

  • Membres
  • 3 messages

Posté 06 mars 2019 - 10:19

Bonjour à tous,

Je rencontre un problème de vérification DKIM sur une faible quantité de messages.

dkim=fail (1024-bit key) reason="fail (body has been altered)"

Cela a souvent pour conséquence la mise en SPAM du message.

Après quelques recherches et comparaisons sur Gmail, j'ai affiné ma recherche sur une modification du Content-Transfer-Encoding au sein du message.

L'envoi et la signature DKIM sont en effet effectué en 8bit, on le voit s'afficher dans les sources sur Gmail :

Content-Transfer-Encoding: 8bit

Par contre, un composant de Zimbra ne semble pas prendre en charge cet encodage et le modifie en :

Content-Transfer-Encoding: quoted-printable

Cette modification du corp du message est à l'origine du fail DKIM.

J'ai trouvé un article parlant de ce problème : https://stbuehler.de...r-encoding.html

Avez-vous une solution pour le support du 8bit dans Zimbra ?

Je vous remercie d'avance pour vos réponses
8.8.11 OSE : DELL -> Ubuntu 16.04 LTS - 1011 Users

#2 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 454 messages
  • LocalisationPlanète Terre

Posté 07 mars 2019 - 15:20

Bonjour,

peut-être un problème proche de celui-ci : https://forums.zimbr...hp?f=15&t=65614

   Cordialement,
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr

#3 DJeremy

DJeremy

    Nouveau membre

  • Membres
  • 3 messages

Posté 08 mars 2019 - 09:48

Bonjour Zimbra Guy

Merci pour ta réponse.

L'échange sur le forum Zimbra.com est très intéressant. J'avais déjà entendu parlé du CRLF. Par contre il semble que cette option soit utilisée pour régler l'ajout d'une ligne blanche en début et/ou en fin de body.

J'ai tout de même essayé des réaliser la modification sur mon installation, hélas sans succès. Le message arrive toujours avec DKIM=fail

Bien à toi,
8.8.11 OSE : DELL -> Ubuntu 16.04 LTS - 1011 Users




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)