Aller au contenu


Modification smtp_helo_name


  • Veuillez vous connecter pour répondre
6 réponses à ce sujet

#1 PierreP

PierreP

    Membre

  • Membres
  • 10 messages

Posté 04 février 2019 - 15:47

Bonjour,

Suite à un incident que nous avons rencontré, nous avons dû modifier notre HELO NAME afin qu'il corresponde au FQDN déclaré dans les DNS publics.
Afin changer ce paramètres nous avons effectué les manips suivante: (source: http://www.sznote.net/?p=1095)

zmlocalconfig -e postfix_smtpd_banner=”mail.xxx.com  ESMTP Postfix”
zmlocalconfig -e  postfix_smtp_helo_name=”mail.xxx.com”
zmmtactl  reload

Malgré ce changement, la commande postconf smtp_helo_name me retournait toujours smtp_helo_name = $myhostname

Ce problème a été réglé en modifiant le paramètre zimbraMtaSmtpHeloName dans la global config

En revanche, lorsque nous ouvrons une connexion HELO à notre serveur, le HELO retourné correspond toujours au FQDN de notre serveur:
nc mail.xxx.com 25 -vv
mail.xxx.com [x.x.x.x] 25 (smtp) open
220 ESMTP mail.xxx.com
HELO mail.xxx.com
250 myhostname.xxx.com


Est-ce normal que le HELO retourné corresponde toujours au FQDN de la mahcine?
Comment faire pour que le HELO retourné corresponde à ce que je souhaite?

Merci de votre aide
Cordialement,
Pierre PROVOOST
VM / Ubuntu 14.04.5 LTS / Zimbra 8.6.2_GA_1200.NETWORK / Cluster:1 MTA, 2 LDAP, 3 STORE

#2 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 509 messages
  • LocalisationPlanète Terre

Posté 04 février 2019 - 16:01

Bonjour Pierre,

d'après ce que tu décris, j'ai l'impression que c'est au niveau de la configuration du serveur lui-même qu'il faut agir.
Je pense que tu as modifié la valeur globale alors qu'il y a une valeur locale de mise.
Vérifie via :
zmprov gs $(zmhostname) zimbraMtaSmtpHeloName

  Cordialement,
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr

#3 PierreP

PierreP

    Membre

  • Membres
  • 10 messages

Posté 05 février 2019 - 08:20

Bonjour Guy,

Tout d'abord, merci de ton retour.

Le résultat de la commande que tu m'a donné me retourne bien la valeur attendu (mail.xxx.com).

J'avais modifié ce paramètre avec la commande suivante: zmprov mcf zimbraMtaSmtpHeloName mail.xxx.com

Cordialement,
Pierre PROVOOST
VM / Ubuntu 14.04.5 LTS / Zimbra 8.6.2_GA_1200.NETWORK / Cluster:1 MTA, 2 LDAP, 3 STORE

#4 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 509 messages
  • LocalisationPlanète Terre

Posté 05 février 2019 - 09:39

Pierre,

si tu parle du retour de la commande EHLO/HELO avec l'indice 250, c'est tout à fait normal.

Cordialement,
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr

#5 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 509 messages
  • LocalisationPlanète Terre

Posté 05 février 2019 - 10:07

Petite précision : le code retour 250 accompagné du FQDN de la machine, ce FQDN correspond à la variable myhostname.
Pour le modifier sur Zimbra il faut faire la command suivante :
zmprov ms $(zmhostname) zimbraMtaMyHostname 'le_nom_de_machine_que_je_veux'
zmcontrol restart

  Cordialement,
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)6 63 18 08 XX / mail : guy.carre+zimbrafr@libremail.fr

#6 Seb28

Seb28

    Nouveau membre

  • Membres
  • 3 messages

Posté 05 février 2019 - 14:03

Merci Guy :)
VM / Ubuntu 14.04.5 LTS / Zimbra 8.6.2_GA_1200.NETWORK / Cluster:1 MTA, 2 LDAP, 3 STORE

#7 PierreP

PierreP

    Membre

  • Membres
  • 10 messages

Posté 05 février 2019 - 14:07

Guy,
Merci de tes retours.
Pierre
VM / Ubuntu 14.04.5 LTS / Zimbra 8.6.2_GA_1200.NETWORK / Cluster:1 MTA, 2 LDAP, 3 STORE




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)