Aller au contenu


Zimbra 8.8.7 - Proxy fonctionne mal


  • Veuillez vous connecter pour répondre
1 réponse à ce sujet

#1 jdh

jdh

    Membre débutant

  • Membres
  • 8 messages

Posté 06 mai 2018 - 19:45

Bonjour,

Une install fraiche de Zimbra 8.8.7 pour migration depuis une viuelle messagerie POP/IMAP,
Version Network Pro (pour client Outlook) / 175 licences.
Install sur Ubuntu 16.04.4 LTS sous forme d'une VM sous VMware : 4 vcpu / 10 G / root = 30G, /opt/zimbra 300G (pour démarrer)

La migration est en cours :
- tous les clients en POP : Zimbra en 'émulation' de l'ancien système : POP ou IMAP) sans SSL, SMTP sans aucun mot de passe (en interne).
- quelques clients passent en Outlook + Connecteur Zimbra + injection du .pst  + archives progressivement (échec avec l'importateur)

Le service Proxy (basé sur Nginx + memcached) fonctionne mal.
D'abord j'ai du l'arrêter (et changer tous les ports : 110, 143 et 443).
Ensuite, je l'ai remis en place avec des pistes indiquées par Zimbra Guy (contact téléphoniques).
Puis j'ai à nouveau changer les ports pour POP et IMAP uniquement (le service Proxy est bien actif).

Traces de telnet host 110 (Zimbra) et 2110 (Proxy) :
root@mail:/home/administrateur# telnet localhost 110
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
+OK mail.xxxxxx.fr Zimbra POP3 server ready
USER jd.hxxxxx@xxxxxx.fr
+OK hello jd.humeau@jcbouy.fr, please enter your password
PASS xxxxxx
+OK server ready
QUIT
+OK mail.xxxxxx.fr Zimbra POP3 server closing connection
Connection closed by foreign host.
root@mail:/home/administrateur# telnet localhost 2110
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
+OK POP3 ready
USER jd.hxxxxx@xxxxxx.fr
+OK
PASS xxxxxx
-ERR internal server error
Connection closed by foreign host.

Quelles pistes de recherches me préconisez vous ?
- log/nginx.log :
2018/05/06 20:24:14 [info] 26667#0: *5973 client 127.0.0.1:37630 connected to 0.0.0.0:2110
2018/05/06 20:24:29 [debug] 26667#0: *5973 pop3 auth state
2018/05/06 20:24:29 [debug] 26667#0: *5973 pop3 login: "jd.hxxxxx@xxxxxx.fr"
2018/05/06 20:24:38 [debug] 26667#0: *5973 pop3 auth state
2018/05/06 20:24:38 [debug] 26667#0: *5973 mail cleanup add: 000000000220FFD8
2018/05/06 20:24:38 [info] 26667#0: *5973 peer closed connection in SSL handshake (111: Connection refused) while SSL handshaking to upstream, client: 127.0.0.1:37630, server: 0.0.0.0:2110, login: "jd.hxxxxx@xxxxxx.fr", upstream: 172.17.1.55:7995 (127.0.0.1:37630->127.0.0.1:2110) <=> (172.17.1.55:56136->)
2018/05/06 20:24:38 [debug] 26667#0: *5973 close mail proxy connection: 21
2018/05/06 20:24:38 [debug] 26667#0: *5973 close mail connection: 18
Le proxy semble faire son boulot mais l'authentification échoue

Merci
Responsable IT d'une groupe de PME industrielles (France/Maghreb/Chine) en développement.
3 install Zimbra dont 2 réalisées (150+35) toutes en Network Pro (Outlook) : 8.7.1 et 8.8.7
Infras sous VMware + NAS.

#2 jdh

jdh

    Membre débutant

  • Membres
  • 8 messages

Posté 06 mai 2018 - 20:21

Je me réponds, suite à mon post :

J'avais désactivé SSL pour POP et IMAP, parce que les clients précédents attaquaient le serveur juste en POP/IMAP nn SSL.
Or le proxy accepte une connexion sans SSL mais ... 'proxyfie' en passant par SSL.
Il fallait donc réactiver SSL ... même si on accepte la connexion en clair par défaut !

Encore un fil qui aurait pu être évité si plus d'examens des logs et plus de tests avaient été réalisés ... Joke
Responsable IT d'une groupe de PME industrielles (France/Maghreb/Chine) en développement.
3 install Zimbra dont 2 réalisées (150+35) toutes en Network Pro (Outlook) : 8.7.1 et 8.8.7
Infras sous VMware + NAS.




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)