Aller au contenu


Aide pour configuration DNS/Réseau


  • Veuillez vous connecter pour répondre
2 réponses à ce sujet

#1 Ifkay

Ifkay

    Nouveau membre

  • Membres
  • 2 messages
  • LocalisationLeguevin

Posté 09 mars 2018 - 22:04

Bonjour/Bonsoir à tous.

Je suis débutant dans l'administration réseau et aussi en Linux , au boulot je doit gérer un serveur ZImbra mais je connais rien en Zimbra et pas grand chose en linux , j'ai donc décidé de monter mon propre serveur Zimbra chez moi ^_^.

Après avoir parcourus plusieurs tuto j'ai réussis à configurer ma VM sous Ubuntu 16.04 serveur et à installer Zimbra 8.8.7, c'est la que les problèmes commences -_-
J'ai de gros problème de configuration DNS, je pense que le soucis vient des différents fichiers de conf du serveur mais aussi de la configuration que j'ai mis en place sur OVH.
J'ai tenté de suivre plusieurs tutos , mais à chaque fois les tutos on l'air de se contredire dans leurs façon d’implémenter les DNS, du coup, après quelques heures , mes fichiers de conf ressemble à une bonne grosse tambouille de tout ça :D.

Je ne peux d'ailleurs même pas consulter le status des services ZImbra ou même les relancer.
"Connect: Unable to determine enabled services from ldap.
Unable to determine enabled services. Cache is out of date or doesn't exist." :unsure:

Voici les configurations de mes différents fichiers de conf :

/etc/network/interfaces
"auto ens32
iface ens32 inet static
address 192.168.1.205
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1
dns-nameservers 192.168.1.1
dns-search mondomaine.fr
# This is an autoconfigured IPv6 interface
iface ens32 inet6 auto
"
/etc/hosts
"127.0.0.1    localhost.mondomaine.fr
192.168.1.205 NomServeur.mondomaine.fr NomServeur

# The following lines are desirable for IPv6 capable hosts
::1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
"
/etc/resolv.conf
"nameserver 192.168.1.1
search mondomaine.fr
"
Voila pour la VM :D
Pour OVH j''ai deux enregistrements, un de type A et un de Type MX

Type A
sous domaine : .mondomaine.fr
TTL : par defaut
CIBLE : monIpPublique

Type MX
sous domaine: .mondomaine.fr
TTL : par défaut
cible : NomServeur.mondomaine.fr

Voila voila , j'avais les idées claire mais maintenant j'ai suivis tellement de tutos différents que je suis completement perdu :wacko:.
Bon l'avantage dans tout ça est que je commence à bien me familiariser avec les commandes linux (toujours rester optimiste)

Le serveur est virtualisé, c'est une VM qui tourne sur un serveur local chez moi (ESXI 5.5)
La box est un abonnement Sosh
Et la vm à un vcpu et 4 go de ram d'allouers
Ubuntu 16.04 Server est à jours

Merci
HP Proliant G6 sous ESXI 5.5
Vm Zimbra 8.8.7

#2 vdagost

vdagost

    Zimbra Jedi

  • Membres
  • PipPipPipPip
  • 528 messages
  • LocalisationLyon

Posté 16 mars 2018 - 10:19

Salut,

Si tu viens d'installer une distribution CentOS il faut purger les règles iptables :

Citation

iptables -F ; iptables-save > /etc/sysconfig/iptables

Très bonne idée de te former chez toi et si tu as la possibilité au boulot de faire un Zimbra de pré-production (une seconde archi identique pour tester les commandes hors-production) ça te sera très pratique à l'avenir.

Pour la conf réseau, tu peux déjà vérifier que les dns fonctionnent sans le fichier host, reverse dns inclus (nslookup -q=PTR), puis remettre le fichier hosts et vérifier que tout est également ok.

Vu l'erreur que tu nous montres, Zimbra ne démarre pas car il n'arrive pas à joindre le serveur Zimbra qui a le rôle d'annuaire LDAP. L'annuaire LDAP a toute la configuration Zimbra centralisée notamment la liste des services à démarrer par chaque serveur Zimbra. Tu as installé un serveur Zimbra standalone ou multi-serveurs ?

Victor
Zimbra 8.8.8 p2 OSS + Zextras
11000 utilisateurs (10 stores)
RHEL 6

#3 Ifkay

Ifkay

    Nouveau membre

  • Membres
  • 2 messages
  • LocalisationLeguevin

Posté 21 mars 2018 - 18:29

Bonsoir Victor,

Non c'est une distribution ubuntu vus que dans mon infra mon serveur est sur ubuntu, j’essaie au maximum de me rapprocher de mon infra.
Malheureusement je manque de temps pour tester un second Zimbra de test , je suis tout seul au service informatique et je gère tout ^^.

Il me semble que j'ai installé un Zimbra standalone, précisément celui si : zcs-8.8.7_GA_1964.UBUNTU16_64.20180223145016.

Petite modification, suite à l'installation d'un routeur chez moi , mon lan est passé en 10.0.0.0, donc mon Zimbra est en 10.0.0.205.

Merci
HP Proliant G6 sous ESXI 5.5
Vm Zimbra 8.8.7




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)