Aller au contenu


problème de configuration auto-provisioining : impossible de login with AD-users


  • Veuillez vous connecter pour répondre
21 réponses à ce sujet

#1 chak

chak

    Membre avancé

  • Membres
  • 34 messages

Posté 28 mars 2017 - 10:10

Bonjour tout le monde ,

j'ai suivi le lien suivant https://wiki.zimbra....sioning_with_AD pour configurer le mode auto-provisionning de Zimbra avec mon serveur AD.

md mail.azerty.local zimbraAutoProvAccountNameMap "samAccountName"
md mail.azerty.local zimbraAutoProvAttrMap description=description
md mail.azerty.local zimbraAutoProvAttrMap displayName=displayName
md mail.azerty.local zimbraAutoProvAttrMap givenName=givenName
md mail.azerty.local zimbraAutoProvAttrMap cn=cn
md mail.azerty.local zimbraAutoProvAttrMap sn=sn
md mail.azerty.local zimbraAutoProvAuthMech LDAP
md mail.azerty.local zimbraAutoProvBatchSize 40
md mail.azerty.local zimbraAutoProvLdapAdminBindDn "CN=Administrateur,CN=Users,DC=sifast,DC=stg"
md mail.azerty.local zimbraAutoProvLdapAdminBindPassword "********"
md mail.azerty.local zimbraAutoProvLdapBindDn "%u@%d"
md mail.azerty.local zimbraAutoProvLdapSearchBase "DC=sifast,DC=stg"
md mail.azerty.local zimbraAutoProvLdapSearchFilter "(cn=%u)"
md mail.azerty.local zimbraAutoProvLdapURL "ldap://172.16.0.228:389"
md mail.azerty.local zimbraAutoProvMode EAGER
md mail.azerty.local zimbraAutoProvNotificationBody "Your account has been auto provisioned.  Your email address is ${ACCOUNT_ADDRESS}."
md mail.azerty.local zimbraAutoProvNotificationFromAddress prov-admin@mail.azerty.local
md mail.azerty.local zimbraAutoProvNotificationSubject "New account auto provisioned"
ms mail.azerty.local zimbraAutoProvPollingInterval "1m"
ms mail.azerty.local +zimbraAutoProvScheduledDomains "mail.azerty.local"

Mais je ne suis pas capable le logguer avec mes AD-users à Zimbra.des erruers apparaissent dans le fichier log!

2017-03-28 11:56:49,440 INFO  [MailboxPurge] [name=administrateurs@mail.azerty.local;mid=8;] purge - Purging messages.
2017-03-28 11:57:07,873 INFO  [AutoProvision] [] autoprov - Auto provisioning accounts on domain mail.azerty.local
2017-03-28 11:57:07,948 INFO  [AutoProvision] [] autoprov - 0 external LDAP entries returned as search result
2017-03-28 11:57:07,948 INFO  [AutoProvision] [] autoprov - Auto Provisioning has finished for now, setting last polled timestamp: 20170328095707.874Z
2017-03-28 11:57:07,950 INFO  [AutoProvision] [] autoprov - Sleeping for 60000 milliseconds.


2017-03-28 11:57:43,389 INFO  [qtp1508221996-34474:https://172.16.0.17:7071/service/admin/soap/GetMailQueueInfoRequest] [name=admin@mail.azerty.local;mid=2;ip=172.16.0.245;ua=ZimbraWebClient - GC56 (Win);] Soa pEngine - handler exception
com.zimbra.common.service.ServiceException: system failure: exception during auth {RemoteManager: mail.azerty.local->zimbra@mail.azerty.local:22}
ExceptionId:qtp1508221996-34474:https://172.16.0.17:7071/service/admin/soap/GetMailQueueInfoRequest:1490695063389:e9040fa61a5f1da4
Code:service.FAILURE

J'utilise la version :
-8.0.9 de Zimbra
-AD 2012

Vos propositions svp :)

Cordialement

#2 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 366 messages
  • LocalisationPlanète Terre

Posté 28 mars 2017 - 10:15

Valide dans un premier temps ton interrogation ldap/AD à la mano.
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)9 81 76 22 XX / mail : guy.carre@capensis.fr
http://www.capensis.fr / http://www.canopsis.com / https://community.capensis.org

#3 chak

chak

    Membre avancé

  • Membres
  • 34 messages

Posté 28 mars 2017 - 10:18

après avoir tapé cette commande
root@mail:/opt/zimbra/bin# ./zmprov desc -a zimbraAutoProvPollingInterval

j'ai obtenu le résultat suivant :

[] INFO: master is down, falling back to replica...
[] FATAL: failed to initialize LDAP client
com.zimbra.cs.ldap.LdapException: LDAP error: : An error occurred while attempting to connect to server mail.azerty.local:389:  java.io.IOException: An error occurred while attempting to establish a connection to server mail.azerty.local:389:  java.net.UnknownHostException: mail.azerty.local
ExceptionId:main:1490696325397:165580ac69d3d43c
Code:ldap.LDAP_ERROR
        at com.zimbra.cs.ldap.LdapException.LDAP_ERROR(LdapException.java:88)
        at com.zimbra.cs.ldap.unboundid.UBIDLdapException.mapToLdapException(UBIDLdapException.java:72)
        at com.zimbra.cs.ldap.unboundid.UBIDLdapException.mapToLdapException(UBIDLdapException.java:38)
        at com.zimbra.cs.ldap.unboundid.LdapConnectionPool.createConnPool(LdapConnectionPool.java:117)
        at com.zimbra.cs.ldap.unboundid.LdapConnectionPool.createConnectionPool(LdapConnectionPool.java:64)
        at com.zimbra.cs.ldap.unboundid.UBIDLdapContext.init(UBIDLdapContext.java:99)
        at com.zimbra.cs.ldap.unboundid.UBIDLdapClient.init(UBIDLdapClient.java:37)
        at com.zimbra.cs.ldap.LdapClient.getInstance(LdapClient.java:63)
        at com.zimbra.cs.ldap.LdapClient.initialize(LdapClient.java:86)
        at com.zimbra.cs.account.ldap.LdapProv.<init>(LdapProv.java:46)
        at com.zimbra.cs.account.ldap.LdapProvisioning.<init>(LdapProvisioning.java:259)
        at com.zimbra.cs.account.ldap.LdapProvisioning.<init>(LdapProvisioning.java:256)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
        at java.lang.Class.newInstance(Class.java:374)
        at com.zimbra.cs.account.Provisioning.getInstance(Provisioning.java:282)
        at com.zimbra.cs.account.Provisioning.getInstance(Provisioning.java:239)
        at com.zimbra.cs.account.ProvUtil.initProvisioning(ProvUtil.java:799)
        at com.zimbra.cs.account.ProvUtil.main(ProvUtil.java:3581)
Caused by: LDAPException(resultCode=91 (connect error), errorMessage='An error occurred while attempting to connect to server mail.azerty.local:389:  java.io.IOException: An error occurred while attempting to establish a connection to server mail.azerty.local:389:  java.net.UnknownHostException: mail.azerty.local')
        at com.unboundid.ldap.sdk.LDAPConnection.connect(LDAPConnection.java:754)
        at com.unboundid.ldap.sdk.LDAPConnection.connect(LDAPConnection.java:686)
        at com.unboundid.ldap.sdk.LDAPConnection.<init>(LDAPConnection.java:518)
        at com.unboundid.ldap.sdk.SingleServerSet.getConnection(SingleServerSet.java:229)
        at com.unboundid.ldap.sdk.ServerSet.getConnection(ServerSet.java:98)
        at com.unboundid.ldap.sdk.LDAPConnectionPool.createConnection(LDAPConnectionPool.java:938)
        at com.unboundid.ldap.sdk.LDAPConnectionPool.<init>(LDAPConnectionPool.java:876)
        at com.unboundid.ldap.sdk.LDAPConnectionPool.<init>(LDAPConnectionPool.java:779)
        at com.unboundid.ldap.sdk.LDAPConnectionPool.<init>(LDAPConnectionPool.java:726)
        at com.zimbra.cs.ldap.unboundid.LdapConnectionPool.createConnPool(LdapConnectionPool.java:113)
        ... 17 more
Caused by: java.io.IOException: An error occurred while attempting to establish a connection to server mail.azerty.local:389:  java.net.UnknownHostException: mail.azerty.local
        at com.unboundid.ldap.sdk.LDAPConnectionInternals.<init>(LDAPConnectionInternals.java:137)
        at com.unboundid.ldap.sdk.LDAPConnection.connect(LDAPConnection.java:744)
        ... 26 more
Je ne comprends pas d'ou provient le problème! vos prpositions svp ?

#4 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 366 messages
  • LocalisationPlanète Terre

Posté 28 mars 2017 - 10:43

Le problème c'est que le LDAP Zimbra n'est pas joignable.
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)9 81 76 22 XX / mail : guy.carre@capensis.fr
http://www.capensis.fr / http://www.canopsis.com / https://community.capensis.org

#5 chak

chak

    Membre avancé

  • Membres
  • 34 messages

Posté 28 mars 2017 - 10:58

Voir le messageZimbra Guy, le 28 mars 2017 - 10:43, dit :

Le problème c'est que le LDAP Zimbra n'est pas joignable.
le domaine de zimbra ne doit pas etre local ?
Est ce que je dois utiliser le ldaps avec le port 636 ?

#6 chak

chak

    Membre avancé

  • Membres
  • 34 messages

Posté 28 mars 2017 - 11:14

qu'est ce que vous me proposez de faire svp ?

#7 chak

chak

    Membre avancé

  • Membres
  • 34 messages

Posté 28 mars 2017 - 12:25

Voir le messageZimbra Guy, le 28 mars 2017 - 10:43, dit :

Le problème c'est que le LDAP Zimbra n'est pas joignable.

c'est bon j'ai maintenant résolu le problème de LDAP Zimbra

root@mail:/opt/zimbra/bin# ./zmprov desc -a zimbraAutoProvPollingInterval

zimbraAutoProvPollingInterval
EAGER mode: required LAZY mode: N/A MANUAL mode: N/A Interval between
successive polling and provisioning accounts in EAGER mode. The actual
interval may take longer since it can be affected by two other
factors: zimbraAutoProvBatchSize and number of domains configured in
zimbraAutoProvScheduledDomains. At each interval, the auto provision
thread iterates through all domains in zimbraAutoProvScheduledDomains
and auto creates up to domain.zimbraAutoProvBatchSize accounts. If
that process takes longer than zimbraAutoProvPollingInterval then the
next iteration will start immediately instead of waiting for
zimbraAutoProvPollingInterval amount of time. If set to 0 when server
starts up, the auto provision thread will not start. If changed from a
non-0 value to 0 while server is running, the auto provision thread
will be shutdown. If changed from 0 to a non-0 value while server is
running, the auto provision thread will be started. . Must be in valid
duration format: {digits}{time-unit}. digits: 0-9, time-unit:
[hmsd]|ms. h - hours, m - minutes, s - seconds, d - days, ms -
milliseconds. If time unit is not specified, the default is
s(seconds).

   type : duration
  value :
   callback : AutoProvPollingInterval
  immutable : false
cardinality : single
requiredIn :
optionalIn : server,globalConfig
  flags : serverInherited
   defaults : 15m
min : 0
max :
id : 1238
requiresRestart :
  since : 8.0.0
deprecatedSince :

mais lorsque j'ajoute un user dans AD je ne le trouve pas dans la liste des users de zimbra ...

2017-03-28 14:21:30,490 INFO  [AutoProvision] [] autoprov - Sleeping for 60000 milliseconds.
2017-03-28 14:22:30,492 INFO  [AutoProvision] [] autoprov - Auto provisioning accounts on domain mail.azerty.local
2017-03-28 14:22:30,563 INFO  [AutoProvision] [] autoprov - 0 external LDAP entries returned as search result
2017-03-28 14:22:30,563 INFO  [AutoProvision] [] autoprov - Auto Provisioning has finished for now, setting last polled timestamp: 20170328122230.493Z

any suggestion please ?

#8 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 366 messages
  • LocalisationPlanète Terre

Posté 28 mars 2017 - 13:14

Quand je vois ça :
[] INFO: master is down, falling back to replica...
[] FATAL: failed to initialize LDAP client

je me dis que l'instance Zimbra a un sérieux problème.
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)9 81 76 22 XX / mail : guy.carre@capensis.fr
http://www.capensis.fr / http://www.canopsis.com / https://community.capensis.org

#9 chak

chak

    Membre avancé

  • Membres
  • 34 messages

Posté 28 mars 2017 - 14:11

Voir le messageZimbra Guy, le 28 mars 2017 - 13:14, dit :

Quand je vois ça :
[] INFO: master is down, falling back to replica...
[] FATAL: failed to initialize LDAP client

je me dis que l'instance Zimbra a un sérieux problème.

j'ai déjà résolu ce problème :)

mon problème maintenant c'est le faite que l'ajout d'un user dans AD ne se fait pas dans zimbra automatiquement ...

#10 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 366 messages
  • LocalisationPlanète Terre

Posté 28 mars 2017 - 14:28

Faut tester comme je le disais précédemment à coup de ldapsearch en utilisant les mêmes arguments que ceux utilisés pour l'auto-prov.
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)9 81 76 22 XX / mail : guy.carre@capensis.fr
http://www.capensis.fr / http://www.canopsis.com / https://community.capensis.org

#11 chak

chak

    Membre avancé

  • Membres
  • 34 messages

Posté 28 mars 2017 - 14:48

Voir le messageZimbra Guy, le 28 mars 2017 - 14:28, dit :

Faut tester comme je le disais précédemment à coup de ldapsearch en utilisant les mêmes arguments que ceux utilisés pour l'auto-prov.
pouvez vous mieux expliquer svp ? j'ai pas bien compris votre remarque .. avec quelle commande ?

#12 chak

chak

    Membre avancé

  • Membres
  • 34 messages

Posté 28 mars 2017 - 15:05

voici le résultat de la commande  #ldapsearch -LLL -x -h 172.16.0.228 -p 389 -D "SIFASTAD\Administrateur" -w "Sifast*2017" -b "dc=sifast,dc=stg"
dn: DC=sifast,DC=stg
objectClass: top
objectClass: domain
objectClass: domainDNS
distinguishedName: DC=sifast,DC=stg
instanceType: 5
whenCreated: 20170313133600.0Z
whenChanged: 20170325115532.0Z
subRefs: DC=ForestDnsZones,DC=sifast,DC=stg
subRefs: DC=DomainDnsZones,DC=sifast,DC=stg
subRefs: CN=Configuration,DC=sifast,DC=stg
uSNCreated: 4099
dSASignature:: AQAAACgAAAAAAAAAAAAAAAAAAAAAAAAA41tK8o8/a027G4gA2OOcVQ==
uSNChanged: 16389
name: sifast
objectGUID:: g2LfZ7frKU2eHJ9nCiVBgA==
creationTime: 131349165324584228
forceLogoff: -9223372036854775808
lockoutDuration: -18000000000
lockOutObservationWindow: -18000000000
lockoutThreshold: 0
maxPwdAge: -36288000000000
minPwdAge: -864000000000
minPwdLength: 7
modifiedCountAtLastProm: 0
nextRid: 1001
pwdProperties: 1
pwdHistoryLength: 24
objectSid:: AQQAAAAAAAUVAAAA6u8Nzl+g/YysaRNk
serverState: 1
uASCompat: 1
modifiedCount: 1
auditingPolicy:: AAE=
nTMixedDomain: 0
dn: CN=test2,CN=Users,DC=sifast,DC=stg
objectClass: top
objectClass: person
objectClass: organizationalPerson
objectClass: user
cn: test2
givenName: test2
distinguishedName: CN=test2,CN=Users,DC=sifast,DC=stg
instanceType: 4
whenCreated: 20170328122230.0Z
whenChanged: 20170328122231.0Z
displayName: test2
uSNCreated: 16842
uSNChanged: 16847
name: test2
objectGUID:: /l5BedmhbEGpzUwBKP8AZw==
userAccountControl: 66048
badPwdCount: 0
codePage: 0
countryCode: 0
badPasswordTime: 0
lastLogoff: 0
lastLogon: 0
pwdLastSet: 131351773515881009
primaryGroupID: 513
objectSid:: AQUAAAAAAAUVAAAA6u8Nzl+g/YysaRNkngQAAA==
accountExpires: 9223372036854775807
logonCount: 0
sAMAccountName: test2
sAMAccountType: 805306368
userPrincipalName: test2@sifast.stg
objectCategory: CN=Person,CN=Schema,CN=Configuration,DC=sifast,DC=stg
dSCorePropagationData: 16010101000000.0Z
# refldap://ForestDnsZones.sifast.stg/DC=ForestDnsZones,DC=sifast,DC=stg
# refldap://DomainDnsZones.sifast.stg/DC=DomainDnsZones,DC=sifast,DC=stg
# refldap://sifast.stg/CN=Configuration,DC=sifast,DC=stg

je ne comprends pas quel est le problème

#13 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 366 messages
  • LocalisationPlanète Terre

Posté 29 mars 2017 - 08:18

Remplace -D "SIFASTAD\Administrateur" par -D "CN=Administrateur,CN=Users,DC=sifast,DC=stg" dans ta commande ldapsearch.
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)9 81 76 22 XX / mail : guy.carre@capensis.fr
http://www.capensis.fr / http://www.canopsis.com / https://community.capensis.org

#14 chak

chak

    Membre avancé

  • Membres
  • 34 messages

Posté 29 mars 2017 - 09:00

Voir le messageZimbra Guy, le 29 mars 2017 - 08:18, dit :

Remplace -D "SIFASTAD\Administrateur" par -D "CN=Administrateur,CN=Users,DC=sifast,DC=stg" dans ta commande ldapsearch.

Merci pour votre réponse. après avoir tapé la commande suivante #ldapsearch -LLL -x -h 172.16.0.228 -p 389 -D "CN=Administrateur,CN=Users,DC=sifast,DC=stg" -w "Sifast*2017" -b "dc=sifast,dc=stg"

j'ai obtenu le même résultat :

dn: DC=sifast,DC=stg
objectClass: top
objectClass: domain
objectClass: domainDNS
distinguishedName: DC=sifast,DC=stg
instanceType: 5
whenCreated: 20170313133600.0Z
whenChanged: 20170325115532.0Z
subRefs: DC=ForestDnsZones,DC=sifast,DC=stg
subRefs: DC=DomainDnsZones,DC=sifast,DC=stg
subRefs: CN=Configuration,DC=sifast,DC=stg
uSNCreated: 4099
dSASignature:: AQAAACgAAAAAAAAAAAAAAAAAAAAAAAAA41tK8o8/a027G4gA2OOcVQ==
uSNChanged: 16389
name: sifast
objectGUID:: g2LfZ7frKU2eHJ9nCiVBgA==
creationTime: 131349165324584228
forceLogoff: -9223372036854775808
lockoutDuration: -18000000000
lockOutObservationWindow: -18000000000
lockoutThreshold: 0
maxPwdAge: -36288000000000
minPwdAge: -864000000000
minPwdLength: 7
modifiedCountAtLastProm: 0
nextRid: 1001
pwdProperties: 1
pwdHistoryLength: 24
objectSid:: AQQAAAAAAAUVAAAA6u8Nzl+g/YysaRNk
serverState: 1
uASCompat: 1
modifiedCount: 1
auditingPolicy:: AAE=
nTMixedDomain: 0
rIDManagerReference: CN=RID Manager$,CN=System,DC=sifast,DC=stg
fSMORoleOwner: CN=NTDS Settings,CN=WIN-AM5ORMDPT2I,CN=Servers,CN=Default-First
-Site-Name,CN=Sites,CN=Configuration,DC=sifast,DC=stg
systemFlags: -1946157056
wellKnownObjects: B:32:6227F0AF1FC2410D8E3BB10615BB5B0F:CN=NTDS Quotas,DC=sifa
st,DC=stg
wellKnownObjects: B:32:F4BE92A4C777485E878E9421D53087DB:CN=Microsoft,CN=Progra
m Data,DC=sifast,DC=stg
wellKnownObjects: B:32:09460C08AE1E4A4EA0F64AEE7DAA1E5A:CN=Program Data,DC=sif
ast,DC=stg
wellKnownObjects: B:32:22B70C67D56E4EFB91E9300FCA3DC1AA:CN=ForeignSecurityPrin
cipals,DC=sifast,DC=stg
wellKnownObjects: B:32:18E2EA80684F11D2B9AA00C04F79F805:CN=Deleted Objects,DC=
sifast,DC=stg
wellKnownObjects: B:32:2FBAC1870ADE11D297C400C04FD8D5CD:CN=Infrastructure,DC=s
ifast,DC=stg
wellKnownObjects: B:32:AB8153B7768811D1ADED00C04FD8D5CD:CN=LostAndFound,DC=sif
ast,DC=stg
wellKnownObjects: B:32:AB1D30F3768811D1ADED00C04FD8D5CD:CN=System,DC=sifast,DC
=stg
wellKnownObjects: B:32:A361B2FFFFD211D1AA4B00C04FD7D83A:OU=Domain Controllers,
DC=sifast,DC=stg
wellKnownObjects: B:32:AA312825768811D1ADED00C04FD8D5CD:CN=Computers,DC=sifast
,DC=stg
wellKnownObjects: B:32:A9D1CA15768811D1ADED00C04FD8D5CD:CN=Users,DC=sifast,DC=
stg
objectCategory: CN=Domain-DNS,CN=Schema,CN=Configuration,DC=sifast,DC=stg
isCriticalSystemObject: TRUE
gPLink: [LDAP://CN={31B2F340-016D-11D2-945F-00C04FB984F9},CN=Policies,CN=Syste
m,DC=sifast,DC=stg;0]
dSCorePropagationData: 16010101000000.0Z
otherWellKnownObjects: B:32:1EB93889E40C45DF9F0C64D23BBB6237:CN=Managed Servic
e Accounts,DC=sifast,DC=stg
masteredBy: CN=NTDS Settings,CN=WIN-AM5ORMDPT2I,CN=Servers,CN=Default-First-Si
te-Name,CN=Sites,CN=Configuration,DC=sifast,DC=stg
ms-DS-MachineAccountQuota: 10
msDS-Behavior-Version: 5
msDS-PerUserTrustQuota: 1
msDS-AllUsersTrustQuota: 1000
msDS-PerUserTrustTombstonesQuota: 10
msDs-masteredBy: CN=NTDS Settings,CN=WIN-AM5ORMDPT2I,CN=Servers,CN=Default-Fir
st-Site-Name,CN=Sites,CN=Configuration,DC=sifast,DC=stg
msDS-IsDomainFor: CN=NTDS Settings,CN=WIN-AM5ORMDPT2I,CN=Servers,CN=Default-Fi
rst-Site-Name,CN=Sites,CN=Configuration,DC=sifast,DC=stg
msDS-NcType: 0
dc: sifast
dn: CN=Users,DC=sifast,DC=stg
objectClass: top
objectClass: container
cn: Users
description: Default container for upgraded user accounts
distinguishedName: CN=Users,DC=sifast,DC=stg
instanceType: 4
whenCreated: 20170313133614.0Z
whenChanged: 20170313133614.0Z
uSNCreated: 5808
uSNChanged: 5808
showInAdvancedViewOnly: FALSE
name: Users
objectGUID:: wh9n3Ye7UEidFehNZn8cnA==
systemFlags: -1946157056
objectCategory: CN=Container,CN=Schema,CN=Configuration,DC=sifast,DC=stg
isCriticalSystemObject: TRUE
dSCorePropagationData: 20170313133901.0Z
dSCorePropagationData: 16010101000001.0Z
dn: CN=test2,CN=Users,DC=sifast,DC=stg
objectClass: top
objectClass: person
objectClass: organizationalPerson
objectClass: user
cn: test2
givenName: test2
distinguishedName: CN=test2,CN=Users,DC=sifast,DC=stg
instanceType: 4
whenCreated: 20170328122230.0Z
whenChanged: 20170328130620.0Z
displayName: test2
uSNCreated: 16842
uSNChanged: 16872
name: test2
objectGUID:: /l5BedmhbEGpzUwBKP8AZw==
userAccountControl: 66048
badPwdCount: 0
codePage: 0
countryCode: 0
badPasswordTime: 0
lastLogoff: 0
lastLogon: 0
pwdLastSet: 131351773515881009
primaryGroupID: 513
objectSid:: AQUAAAAAAAUVAAAA6u8Nzl+g/YysaRNkngQAAA==
accountExpires: 9223372036854775807
logonCount: 0
sAMAccountName: test2
sAMAccountType: 805306368
userPrincipalName: test2@sifast.stg
objectCategory: CN=Person,CN=Schema,CN=Configuration,DC=sifast,DC=stg
dSCorePropagationData: 16010101000000.0Z
mail: test2@sifast.stg

mon domaine AD= sifast.stg (j'utilise AD 2012)
mon domaine zimbra=mail.lazerty.local

mon fichier de configuration /tmp/autoprov.txt est le suivant:

md mail.azerty.local zimbraAutoProvAccountNameMap "samAccountName"
md mail.azerty.local +zimbraAutoProvAttrMap description=description
md mail.azerty.local +zimbraAutoProvAttrMap displayName=displayName
md mail.azerty.local +zimbraAutoProvAttrMap givenName=givenName
md mail.azerty.local +zimbraAutoProvAttrMap cn=cn
md mail.azerty.local +zimbraAutoProvAttrMap sn=sn
md mail.azerty.local zimbraAutoProvAuthMech LDAP
md mail.azerty.local zimbraAutoProvBatchSize 40
md mail.azerty.local zimbraAutoProvLdapAdminBindDn "CN=Administrateur,CN=Users,DC=sifast,DC=stg"
md mail.azerty.local zimbraAutoProvLdapAdminBindPassword "Sifast*2017"
md mail.azerty.local zimbraAutoProvLdapBindDn "%u@sifast.stg"
md mail.azerty.local zimbraAutoProvLdapSearchBase "CN=Users,DC=sifast,DC=stg"
md mail.azerty.local zimbraAutoProvLdapSearchFilter "(samAccountName=%u)"
md mail.azerty.local zimbraAutoProvLdapURL "ldap://172.16.0.228:389"
md mail.azerty.local zimbraAutoProvMode EAGER
md mail.azerty.local zimbraAutoProvNotificationBody "Your account has been auto provisioned.  Your email address is ${ACCOUNT_ADDRESS}."
md mail.azerty.local zimbraAutoProvNotificationFromAddress prov-admin@mail.azerty.local
md mail.azerty.local zimbraAutoProvNotificationSubject "New account auto provisioned"
ms mail.azerty.local zimbraAutoProvPollingInterval "1m"
ms mail.azerty.local +zimbraAutoProvScheduledDomains "mail.azerty.local"


#15 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 366 messages
  • LocalisationPlanète Terre

Posté 29 mars 2017 - 09:08

Attention la casse pour
sAMAccountName

De plus ta commande ldapsearch n'est pas identique en tout point à ton paramétrage Zimbra.
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)9 81 76 22 XX / mail : guy.carre@capensis.fr
http://www.capensis.fr / http://www.canopsis.com / https://community.capensis.org

#16 chak

chak

    Membre avancé

  • Membres
  • 34 messages

Posté 29 mars 2017 - 09:11

Voir le messageZimbra Guy, le 29 mars 2017 - 09:08, dit :

Attention la casse pour
sAMAccountName

De plus ta commande ldapsearch n'est pas identique en tout point à ton paramétrage Zimbra.

merci pour ta réponse mais je ne comprends pas le problème ? un problème de filtre ? qu'est ce que je dois faire svp ?
J'ai vraiment besoin que cette solution fonctionne ! je serais très reconnaissante si vous pourrez m'aider .

#17 chak

chak

    Membre avancé

  • Membres
  • 34 messages

Posté 29 mars 2017 - 11:27

je réexplique mon problème:

La 1er synchronisation d'utilisateur avec mon AD fonctionne très bien et ensuite plus rien.
Quand j'ajout ou je modifie un utilisateur AD il ne se passe rien dans Zimbra.
Je trouve que c'est le problème de plusieurs personnes d'après le forum mais je ne vois pas de solution ! est ce que quelqu'un peut nous expliquer ce point ? 1ere synchro réussie et après pourquoi lors de l'ajout d"un user dans AD rien ne se passe ?

#18 chak

chak

    Membre avancé

  • Membres
  • 34 messages

Posté 31 mars 2017 - 11:58

Je tiens à préciser quelque chose .. lorsque je change mon filtre zimbraAutoProvLdapSearchFilter "(CN=%u)" à zimbraAutoProvLdapSearchFilter "(samAAccountname=%u)" la synchronisation aboutit pour une fois mais puis plus rien lorsque j'ajoute un nouveau user. je rechange  zimbraAutoProvLdapSearchFilter "(samAAccountname=%u)" à zimbraAutoProvLdapSearchFilter "(CN=%u)" ca aboutit aussi pour le nouveau user mais après plus rien ! quelqun peut m'expliquer le problème svp ?

#19 Zimbra Guy

Zimbra Guy

    Zimbra Jedi

  • Modérateurs
  • 5 366 messages
  • LocalisationPlanète Terre

Posté 31 mars 2017 - 15:08

ça à l'air de correspondre à ce bug https://bugzilla.zim...ug.cgi?id=82587
Guy Carré, professionel certifié Zimbra, Contributeur Zimbra
tel : +33 (0)9 81 76 22 XX / mail : guy.carre@capensis.fr
http://www.capensis.fr / http://www.canopsis.com / https://community.capensis.org

#20 chak

chak

    Membre avancé

  • Membres
  • 34 messages

Posté 01 avril 2017 - 23:45

oui je comprends d'après les forums que j'ai lu que ça correspond à ce bug mais je n'ai pas compris comment le résoudre ... est ce que vous pouvez me donner des consignes pour le résoudre ? merci




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)